locked
Xamarin UITests RRS feed

  • Question

  • User207113 posted

    Hello Guys: Anyone else having problem executing tests locally on simulator or device?

    When on device, I get this error message: "The directory name is invalid", when starting app like this:

    return ConfigureApp.iOS.AppBundle("/Users/wambosi/Desktop/AppCenter.ipa").DeviceIdentifier("49E2C4B2-F548-4C95-8EA8-AA31564EB9A1").StartApp();

    and when on simulator, it outrightly says that "App must be installed...". This is in the new Xamarin version 6.0 build 5174.

    Xamarin Studio Business Version 6.0 (build 5174) Installation UUID: 497a8621-39a1-491c-9606-2b2c5ca330b4 Runtime: Mono 4.4.0 (mono-4.4.0-branch-c7-baseline/5995f74) (64-bit) GTK+ 2.24.23 (Raleigh theme)

    Package version: 404000182
    

    Xamarin.Profiler Not Installed

    Apple Developer Tools Xcode 7.3.1 (10188.1) Build 7D1014

    Xamarin.iOS Version: 9.8.0.323 (Xamarin Business) Hash: 39ebb77 Branch: cycle7 Build date: 2016-06-01 21:23:15-0400

    Xamarin.Android Version: 6.1.0.71 (Xamarin Business) Android SDK: /Users/ashukla/Library/Developer/Xamarin/android-sdk-macosx Supported Android versions: 4.0.3 (API level 15) 4.4 (API level 19) 6.0 (API level 23)

    SDK Tools Version: 24.4.1 SDK Platform Tools Version: 23.0.1 SDK Build Tools Version: 23.0.1

    Java SDK: /usr java version "1.7.071" Java(TM) SE Runtime Environment (build 1.7.071-b14) Java HotSpot(TM) 64-Bit Server VM (build 24.71-b01, mixed mode)

    Android Designer EPL code available here: https://github.com/xamarin/AndroidDesigner.EPL

    Xamarin Android Player Not Installed

    Xamarin.Mac Version: 2.8.0.323 (Xamarin Business)

    Build Information Release ID: 600005174 Git revision: 694a75f040b7f2309bc43d4f78a3a6572ca898bf Build date: 2016-06-01 17:28:08-04 Xamarin addins: 33f406fa2dcf214012c78cb846585f062b2e1d24 Build lane: monodevelop-lion-cycle7-baseline

    Operating System Mac OS X 10.11.5 Darwin Silvers-Mac-mini.local 15.5.0 Darwin Kernel Version 15.5.0 Tue Apr 19 18:36:36 PDT 2016 root:xnu-3248.50.21~8/RELEASEX8664 x86_64

    Wednesday, June 8, 2016 4:43 PM

Answers

  • User89714 posted

    @Anurag.9113 - I suggest posting (or cross-posting) UITest questions in the https://forums.xamarin.com/categories/xamarin-test-cloud forum, as you are more likely to get help there.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, June 9, 2016 3:29 PM

All replies

  • User207113 posted

    Now, I'm getting "Could not find key: AppleSdkRoot".

    Wednesday, June 8, 2016 8:24 PM
  • User207113 posted

    WHAT THE **. This error message does not make any sense at all? This app bundle is not valid for running on a simulator. To fix this issue please ensure that your target device is a simulator. DTPlatformName is 'iphoneos', not 'iphonesimulator' in the apps Info.plist.

    Thursday, June 9, 2016 2:54 PM
  • User89714 posted

    @Anurag.9113 - I suggest posting (or cross-posting) UITest questions in the https://forums.xamarin.com/categories/xamarin-test-cloud forum, as you are more likely to get help there.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, June 9, 2016 3:29 PM