none
CodeDom : Compiler Option for v4.5 RRS feed

  • Question

  • Hi,

     I am trying to generate a simple assembly using CodeDOM. I would want the assembly to target .Net 4.5 framework. But if i provide "CompilerOption" as "v4.5" I am getting an error as mentioned in this post : http://stackoverflow.com/questions/9591584/using-csharpcodeprovider-with-net-4-5-beta

    If I specify "v4.0" , I resultant assembly is doesnt seem to be targetting "v4.5" [ I verified it by adding it as a reference to a v4.0 project and it still works].

    How do I create an assembly targetting v4.5 using CodeDom ? I tried by adding CompilerParameters.ReferencedAssemblies to explicitly point to v4.5 System.dll and System.Core.dll. No luck !

    Friday, November 2, 2012 1:29 AM

Answers

All replies