locked
Undefined object type Server RRS feed

  • Question

  • User-1296623750 posted

    Hi, folks.

    I'm trying to run some PowerShell scripts, like Start-WebAppPool, for a specific server and I got the following error:

    PS C:\Users\xyz> Start-WebAppPool -Name 'abc'
    Start-WebAppPool : Undefined object type Server.
    Parameter name: nodeName
    At line:1 char:1
    + Start-WebAppPool -Name 'abc'
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [Start-WebAppPool], ArgumentException
        + FullyQualifiedErrorId : invalidArgument,Microsoft.IIs.PowerShell.Provider.StartAppPoolCommand

    I have 10 servers and I'm able to run the same command this command in 9 of then. Even when tried to Import-Module WebAdministration it doesn't work.

    Any idea of what's going on?

    Thanks!

    Tuesday, May 14, 2019 10:06 PM

All replies

  • User-848649084 posted

    Hi,

    Does this user have administrator right? or this user has access to remote iis?

    Regards,

    Jalpa

    Wednesday, May 15, 2019 5:34 AM
  • User-1296623750 posted

    Hi, Jalpa.

    Yes, I have admin rights and remote access to to IIS.

    Thanks,

    Wednesday, May 15, 2019 9:28 PM
  • User-848649084 posted

    Hi,

    Try to use the below steps to start and stop the application pool on the remote server:

    1. Run PowerShell as administrator.
    2. Run command:  Import-Module WebAdministration
    3. Run command: Invoke-Command -ComputerName "REMOTE_SERVER" -ScriptBlock { Start-WebAppPool -Name "apppool name" }

     

    Thursday, May 16, 2019 6:43 AM
  • User-1296623750 posted

    Hi, Jalpa.

    I ran the command from other server and I got the same error.

    Thanks,

    Thursday, May 16, 2019 1:10 PM
  • User-848649084 posted

    Hi,

    Does your all server in the same network? also, check that you enable remote management service in IIS.

    Friday, May 17, 2019 7:10 AM