none
Hive-based Registry Initialization Problem Win EC 7 RRS feed

  • Question

  • Hey

    Trying to setup a nk.bin file with Hive-based Registry but the keyboard wont cooperate.
    The keyboard worked before I tried to set up the Hive-based Registry.

    When building the OS I have activated the Hive-based Registry at the Catalog Items View in VS 2008 and edited the 
    C:\WINCE700\public\COMMON\oak\files\common.reg with this:

    [HKEY_LOCAL_MACHINE\init\BootVars]
       "SystemHive"="My Documents\\system.hv"
       "ProfileDir"="My Documents"
       "Flags"=dword:3
       "NoDefaultUser"=dword:1
    [HKEY_LOCAL_MACHINE\System\StorageManager\Profiles\HDProfile]
        "MountAsBootable"=dword:1
    ; END HIVE BOOT SECTION

     When booting the nk.bin with this setting the keyboard does not work(the mouse works) but the system remembers the change I have done. 
    I have tried selecting/deselecting different types of options in the Catalog Items View in VS 2008 but I cant get it to work. 

    What could be the problem?  

    Tuesday, July 12, 2011 7:04 AM

All replies

  • First of all, don't edit files in public\common\*.  If you want to make a registry change, do it by overriding in one of your platform or project reg files.  Next, have you tried a debug build?  The output from a debug build will generally give you more insight as to what is going on...
    Dean Ramsier eMVP BSQUARE Corporation
    Tuesday, July 12, 2011 1:13 PM
  • Hey

    i have added the code in platform.reg and I also changed the BSP from CEPC: x86 to a custom Intel_CS: x86 and it seems to work. (I'm using a wafer 945GSE)
    Thanks for input :) 



     

    Thursday, July 14, 2011 11:47 AM