locked
Silverlight application not working RRS feed

  • Question

  • I installed silverlight 2.0 using silverlight chainer. It worked on the 1st day. But after installing some updates(I think so), when i open the Page.Xaml in Visual studio, it is showin some error like "Problem loading page. The document contains some errors that must be fixed before loading the page. when i run the page an error is shown in the error list (Error:  The type initializer for 'MS.Internal.Silverlight.Host.RuntimeInterop' threw an exception. ) and the page is showing "Install Silverlight" image. When i checked with other websites, it is working fine. pls give me a solution

    Monday, December 8, 2008 1:52 AM

Answers

  • Hello,

    I think the one that you installed might be old version of Silverlight (maybe, beta2 or etc )  Please try to do the following steps ~

    1. Uninstall all Silverlight (plugin, SDK, Tool for VS) from your machine.
    2. Check whether you have installed .NET 3.5 sp1 and VS sp1. If you don't have those service packs, please download and install them first.
    3. Go to this page http://www.microsoft.com/downloads/details.aspx?FamilyId=c22d6a7b-546f-4407-8ef6-d60c8ee221ed&displaylang=en and download the Silverlight_Tools.exe
    4. Close all browsers and VS.
    5. Install it on your machine.
    6. After that, create new Silverlight project in your VS and see whether it's working fine or not.
    7. And then, please check the project that you have is using the latest ver of SL or not.

     

    Monday, December 8, 2008 1:59 AM
  • Hi, u donot need the silverlight chainer anymore. Please follow this steps.

    This is the procedure i followed and it worked perfectly

    This works for both XP and Vista.

    1. VS 2008 installed first, then VS2008 SP1

    2. install Silverligh_tools.exe 72.3MB with internet connection and everything worked perfectly.

    3. Then  install Blend Trial.exe and afterwards Blend SP1. The blend now works perfectly and also is integrated with S2 RTW application.

    Before installing you have to uninstall the following things.

    Just go to control panel,

    2. Click add/remove programs

    You will find 3 silverlight icon

    a, Unstall Microsoft Silverlight Beta pluggins

    b, Uninstall Microsoft Beta  Silverlight 2 SDK

    c, Uninstall Silverlight Beta Tools for VS 2008 SP1

    when i tried to install silverlight tools it is asking for vs sp1. wher can i dwnload sp1 for vs?

    You can get VS2008 SP1 link here

    http://silverlight.net/GetStarted/

    If this post was helpful then please 'Mark as Answer'

    Sharker Khaleed Mahmud
    Software Developer
    (MCP,MCTS,MCPD[web])

    This credits that member, earns you a point and marks your thread as Resolved so we will all know you have been helped

    Tuesday, December 9, 2008 4:37 AM

All replies

  • Hello,

    I think the one that you installed might be old version of Silverlight (maybe, beta2 or etc )  Please try to do the following steps ~

    1. Uninstall all Silverlight (plugin, SDK, Tool for VS) from your machine.
    2. Check whether you have installed .NET 3.5 sp1 and VS sp1. If you don't have those service packs, please download and install them first.
    3. Go to this page http://www.microsoft.com/downloads/details.aspx?FamilyId=c22d6a7b-546f-4407-8ef6-d60c8ee221ed&displaylang=en and download the Silverlight_Tools.exe
    4. Close all browsers and VS.
    5. Install it on your machine.
    6. After that, create new Silverlight project in your VS and see whether it's working fine or not.
    7. And then, please check the project that you have is using the latest ver of SL or not.

     

    Monday, December 8, 2008 1:59 AM
  • when i tried to install silverlight tools it is asking for vs sp1. wher can i dwnload sp1 for vs?

    Monday, December 8, 2008 5:55 AM
  • Hi, u donot need the silverlight chainer anymore. Please follow this steps.

    This is the procedure i followed and it worked perfectly

    This works for both XP and Vista.

    1. VS 2008 installed first, then VS2008 SP1

    2. install Silverligh_tools.exe 72.3MB with internet connection and everything worked perfectly.

    3. Then  install Blend Trial.exe and afterwards Blend SP1. The blend now works perfectly and also is integrated with S2 RTW application.

    Before installing you have to uninstall the following things.

    Just go to control panel,

    2. Click add/remove programs

    You will find 3 silverlight icon

    a, Unstall Microsoft Silverlight Beta pluggins

    b, Uninstall Microsoft Beta  Silverlight 2 SDK

    c, Uninstall Silverlight Beta Tools for VS 2008 SP1

    when i tried to install silverlight tools it is asking for vs sp1. wher can i dwnload sp1 for vs?

    You can get VS2008 SP1 link here

    http://silverlight.net/GetStarted/

    If this post was helpful then please 'Mark as Answer'

    Sharker Khaleed Mahmud
    Software Developer
    (MCP,MCTS,MCPD[web])

    This credits that member, earns you a point and marks your thread as Resolved so we will all know you have been helped

    Tuesday, December 9, 2008 4:37 AM