Activate button not working in Site Collection features


  • I just created a new web application and then Site Collection with "Team Site" template. Now when I want to activate "Publishing infrastructure" the "ACTIVATE" button is not working ..even not any button is working..whenever click on any button the page scrolls on the top.

    Friday, December 27, 2013 11:14 AM


  • Issue solved in my new thread

    • Marked as answer by Josh The Flame Tuesday, December 31, 2013 12:47 PM
    Tuesday, December 31, 2013 12:16 PM

All replies

  • HI Josh,

    for me also faced same problem,

    but i navigated to other pages and tryed 2 times its activated, some times its taking time to activate the feature.



    Friday, December 27, 2013 11:47 AM
  • i wait for atleast more then 4 mintutes..its a mere AJAX operation on buttons but unable to understand why its not working. SP 2013 brought so many changes in the product for sure.
    Friday, December 27, 2013 12:17 PM
  • Are you trying to activate it on the root site or a sub-site?  It might also be worthy activating a console view within browser developer tools to see where the activation request is getting stuck.  That way the community can help you out more.

    Steven Andrews
    SharePoint Business Analyst: LiveNation Entertainment
    Twitter: Follow @backpackerd00d
    My Wiki Articles: CodePlex Corner Series
    Please remember to mark your question as "answered" if this solves (or helps) your problem.

    Friday, December 27, 2013 3:11 PM
  • activating on Root site.
    Monday, December 30, 2013 8:28 AM
  • Hi,

     Please refer the below url, which will guide to you to use Powershell to activate the publishing feature.

    If its not helping you please let us know

    Monday, December 30, 2013 8:51 AM
  • Did you check if JavaScript was enabled in your browser ?

    Kind Regards

    Twitter: Follow @bjoern_rapp

    Monday, December 30, 2013 8:58 AM
  • Hi,

    According to your post, my understanding is that you could not activate the “Publishing infrastructure” feature.

    To narrow the issue, you can check with the following steps.

    Did the issue occur in other browsers? You can use other browsers, such as Firefox or Chrome, to check whether it works.

    Did the issue occur in other site collections? You can create a new site collection or use other site collections in other web applications to check whether it works.

    You can also check the event log and ULS log to see if anything unexpected occurred.

    To check event log, click the Start button and type “Event Viewer” in the Search box.

    For SharePoint 2013, by default, ULS log is at      

    C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\LOGS

    Thanks & Regards,


    Jason Guo
    TechNet Community Support

    Monday, December 30, 2013 10:44 AM
  • Well when i went into Site Settings-> Page Layouts I added "Publishing" and publishing activated automatically.
    Monday, December 30, 2013 11:59 AM
  • Issue solved in my new thread

    • Marked as answer by Josh The Flame Tuesday, December 31, 2013 12:47 PM
    Tuesday, December 31, 2013 12:16 PM