locked
Error 1456 Received Despite all servers running SP2 when DB Mirroring Witness is Added RRS feed

All replies

  • Which edition of SQL you have installed for principal, mirror and witness server.

    Sunday, June 15, 2008 3:57 PM
  • Could you post the output of Select @@version;

     

    Did you restart the system after applying SP2 , was SP2 application successful.

     

     

    Tuesday, June 17, 2008 4:05 AM
  •  

    All Versions of SQL are STD with Build 9.0.3054:

     

    SQL1 - Primary

    Microsoft SQL Server 2005 - 9.00.3054.00 (X64)   Mar 23 2007 18:41:50   Copyright (c) 1988-2005 Microsoft Corporation  Standard Edition (64-bit) on Windows NT 5.2 (Build 3790: Service Pack 2)

     

    SQL2 - Secondary

    Microsoft SQL Server 2005 - 9.00.3054.00 (X64)   Mar 23 2007 18:41:50   Copyright (c) 1988-2005 Microsoft Corporation  Standard Edition (64-bit) on Windows NT 6.0 (Build 6001: Service Pack 1)

     

    SQL3 - Wintness and domain Controller

    Microsoft SQL Server 2005 - 9.00.3054.00 (X64)   Mar 23 2007 18:41:50   Copyright (c) 1988-2005 Microsoft Corporation  Standard Edition (64-bit) on Windows NT 6.0 (Build 6001: Service Pack 1)

    Tuesday, June 17, 2008 5:21 PM
  •  

    Tried the steps in the KB Article, but this also did not work for me.  I checked the DNS Server which is the same server as the witness since it is the DC and the network adapter is registered correctly.
    Tuesday, June 17, 2008 6:03 PM
  • Hi Jsani,

     

    I got the same error.

     

    Msg 1456, Level 16, State 3, Line 1
    The ALTER DATABASE command could not be sent to the remote server instance 'TCP://server.domain.COM:5022'. The database mirroring configuration was not changed. Verify that the server is connected, and try again.

     

    Are you able to figure out the issue.  Let me know if you find something.

    Thursday, July 17, 2008 2:13 PM
  •  

    I was not able to figure it out despite trying several fixes recommended in the MS KB and by other posters. I ended up building another Virtual Machine for the witness on which I ran SQL 2005 Express.  Everything is working now as it is supposed to,
    Thursday, July 17, 2008 3:02 PM
  • Can you give me the VM configuration like OS edition, Whether names pipes enabled on SQL instance for the witness server etc

     

    Also what makes the VM different than your original witness server?

    Thursday, July 17, 2008 3:32 PM
  • All my SQL instances are running with 9.0.3200

    Thursday, July 17, 2008 5:25 PM
  • OS is server 2008 but this should not matter.  SQL 2005 Express SP2 with all aditional updates applied, named pipes and TCP/IP enabled.  There is some bug with Mirroring in general when using the SQL Natve Client or ADO.Net whereby if you do not enable named pipes and make it higher in the priority list than TCP/IP, mirroring pukes from the application perspective so named pipes is enabled in our environment and is the default protocol.

    Thursday, July 17, 2008 5:42 PM
  • I too am experiencing this issue, minus the 2008 domain controller.  Adding named pipes isn't an option for me.  Has anybody run across other documentation?

     

    John T

    Monday, July 21, 2008 11:36 PM
  • Try this:

     

    Fail the DBs over to the Secondary and then remove mirroring.  Remove SQL completely from the original primary and re-install to the same level.  Then re-enable mirroring on the original primary with a witness.  This worked for me without changing the named pipes priority.  The latter fix was to solve a differnt problem - our .net web application would not attempt to connect to the mirror server after a fail-over depsite the correct connection strings.  If you have a lot of cans, I have some automation scripts that I used to initiate and remove mirroring.

     

    J

    Tuesday, July 22, 2008 2:48 AM
  • Thanks for the suggestion.  I'm glad to know this worked for you.  It won't work for me.  I have multiple instances of SQL server on the principal, and only one instance has a mirrored database.  I'm going to have to open a support case with microsoft.  IF I get a workable solution, I'll post back to inform anybody interested.

     

    John T

    Tuesday, July 22, 2008 4:59 PM