none
Is 2.0.11888 the latest Java Function Runtime and if so why isn't it running RRS feed

  • Question

  • As best I can interpret the Functions runtime announcement from June 20, 2.0.11888 is the latest runtime for Java, but it is not appearing as the runtime version for a specific function that has been updated using latest Maven tools and deployed.

    If it 2.0.11888 should be running, what is the specific function extension string that should be set as "FUNCTION_EXTENSION_VERSION"?

    Right now the runtime version shown by Azure is 2.0.11857.0 (beta).

    Thanks

    Friday, June 22, 2018 7:11 PM

Answers

All replies

  • Can you provide me a link to the announcement you are referring to? 
    Friday, June 22, 2018 8:21 PM
    Moderator
  • e-mail from Alexey Rodionov (result of subscribing to announcements):

    A new version of the Azure Functions Runtime Preview 2.0.11888 is being deployed.
    Please refer to the latest release notes on the release page here for details:
    https://github.com/Azure/azure-functions-host/releases/tag/v2.0.11888-alpha
    This release has breaking changes:
    • Temporary 64-bit platform is not supported. Please switch to 32-bit in "General Settings" if you use 64-bit platform. Next release will add 64-bit support again.

    Friday, June 22, 2018 9:20 PM
  • I just tried updating my functions as well but I am also only seeing 2.0.11857.0 (beta).

    I am assuming this it not actually fully available as from the article you provided you can see it is still tagged as pre-release. So it will not be automatically applied. Hence, they provided the source code for download if you really wanted to try it out. 

    If you are wondering when exactly it will move out of pre-release I would suggest opening an issue directly on that GitHub repo as the product group is active there and could give you a more definitive answer. Otherwise, I would just suggest staying with 2.0.11857.0 (beta). until they make it GA

    Friday, June 22, 2018 10:24 PM
    Moderator
  • With respect, I would like some consistency in what an e-mailed announcement for an update and a breaking change means. I got burned when the site was upgraded to 11857, which introduced breaking changes. I was advised on this forum to subscribe to the announcements, which I dutifully did. So when I received the e-mail announcing the 2.0.11888 update, I assumed that again it had been deployed  (specifically the e-mails says "is being deployed"). If it has not been deployed in east us, tell me that. I know that Java functions, as an offering by MS, are not General Availability (to me, that is what the pre-release tag means). Other than the 64-bit issue, there was no indication of any other problems. It appears that again MS is out of synch with itself. Somebody says something is being deployed, and either it is not, or the tools aren't ready.
    Friday, June 22, 2018 11:48 PM
  • Thanks Jack. I am looking into it further and will let you know what I find. 
    Saturday, June 23, 2018 4:16 PM
    Moderator
  • Hi Jack,

    The main point of the announcement (in this case https://github.com/Azure/app-service-announcements/issues/117) is for it to be posted before any deployment starts, so users can prepare for it without getting suddenly broken. At it stands, it is only partially deployed (e.g. you can try it in West Central US).

    Also, you can use the associated discussion thread (https://github.com/Azure/app-service-announcements-discussions/issues/54) for any questions related to the announcement.

    thanks,
    David

    • Marked as answer by -jack- Monday, June 25, 2018 6:16 PM
    Saturday, June 23, 2018 11:50 PM
  • David,

    Deploying to westcentralus with a specific version (2.0.11888) in the POM FUNCTIONS_EXTENSION_VERSION seems to work. Azure displays a message to the effect that the runtime version is invalid, but that 2.0.11888.0 will be used. No tweaking that we could find made that message go away, but the function works, and subjectively seems a bit faster with WEBSITE_USE_PLACEHOLDER=1 (this is why we wanted to begin working with 2.0.11888).

    I understand that MS wants to stage deployments, but surely you could do a better job of communicating the order of regions, and provide more specificity of when regions will get the deployments. As far as I can tell there can be only one Java function runtime on a local machine, and while I suppose I could set up multiple virtual machines for different run times, that's a pain to keep track of.

    Anyway, thanks for the guidance.

    Jack

    Monday, June 25, 2018 6:16 PM
  • Fair point about communicating a bit more details about the schedule. It should be done either by tomorrow or Wednesday.

    To use 2.0.11888, you should just leave the version as Beta, which basically means latest 2.x.

    Monday, June 25, 2018 6:20 PM
  • David,

    I spoke too soon. While one of my functions seems to be deployed in west central us, and may be running the 2.0.11888 runtime, it is flakey.

    (1) I can't really confirm what runtime is active:

    (2) when I click the function name in the portal (Function Apps -> select function -> function name) a dialog box appears:Error: The function runtime is unable to start.

    (2) when I attempt to set the access authorization to "Function" the another error dialog appears: Error Unauthorized - /api/passthrough

    BUT, leaving the function in Anonymous access, it does run - but like I said, I am not sure what runtime is being used.

    I need to get this sorted so I can believe that I am really testing with the 2.0.11888 runtime.

    When I run locally, it is Java runtime 1.0.0-beta5.

    This information comes from a new deployment (deleted the Function App on Azure with the same name, then deployed the new function App).


    • Edited by -jack- Monday, June 25, 2018 10:42 PM images not displayed
    Monday, June 25, 2018 10:40 PM
  • Hi Jack,

    I think it's best to decouple two different things:

    1. The state of the 2.0.11888 deployment
    2. Specific issues that you may be having with that build (compared to the previous build)


    For #1, if you're in West Central US, you're definitely using that new build. If you share your test app name, I can double confirm.

    For #2, it's best to report this on the discussion thread for the deployment, to make sure the right people are seeing it.

    thanks,
    David

    Monday, June 25, 2018 10:58 PM
  • blob-manage-fields-<2018 date/time stamp>

    I will post to the discussion thread.

    Thanks

    Monday, June 25, 2018 11:17 PM
  • I found the app, and confirmed that it's running 2.0.11888.
    Monday, June 25, 2018 11:25 PM