locked
How to use azure rms in existing on-premise ad rms environment RRS feed

  • Question

  • I have installed rms sharing application.Choose a office file and right-click file , on-premise rms templates display,but auzre rms templates don't display.How to choose azure rms template to protect file?

    Tuesday, January 26, 2016 6:03 AM

Answers

  • You are correct in that the RMS sharing app does not support logging in as different users at this time.

    The main concern I have is that you don't want to have AD RMS and Azure RMS coexisting simultaneously. This is an unsupported configuration. Typically they only run simultaneously for as long as it takes you to migrate your AD RMS key to Azure.

    For migration information please see the following.

    Off the top of my head I am not aware of a way to make the RMS sharing app "forget" the account you signed in with the first time.  You should look in "HKCU\SOFTWARE\Classes\Local Settings\Software\Microsoft\MSIPC" for starters. Even try exporting the key and deleting it and try again.

    You could log in as a different user on the machine an invoke the sharing app. That should also allow you to sign in anew.

    /Steve


    Steve L [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, January 27, 2016 1:14 PM

All replies

  • When you start the Sharing App, with which Account are you logging in?

    Have you assigned a Azure AD premium License to your user? (required for RMS)


    Blog Twitter

    Tuesday, January 26, 2016 2:09 PM
  • Thanks for your reply!

    When I start the sharing app, the default user is local domain user. Even if sharing app is reinstalled,the sharing app is started for the first time,the default user is still local domain user.I saw the article in msdn, the feature of changing user for the sharing app is not supported now.How to set the azure ad user in the sharing app for the first time?

    Which license is Azure AD premium License? Office 365 Enterprise E3? Office 365 Enterprise E1?
    Should the license you refer to be assigned to azure ad user?
    But Azure rms works well in environment that don't on-premise ad rms.

     

     

    Wednesday, January 27, 2016 1:01 AM
  • You are correct in that the RMS sharing app does not support logging in as different users at this time.

    The main concern I have is that you don't want to have AD RMS and Azure RMS coexisting simultaneously. This is an unsupported configuration. Typically they only run simultaneously for as long as it takes you to migrate your AD RMS key to Azure.

    For migration information please see the following.

    Off the top of my head I am not aware of a way to make the RMS sharing app "forget" the account you signed in with the first time.  You should look in "HKCU\SOFTWARE\Classes\Local Settings\Software\Microsoft\MSIPC" for starters. Even try exporting the key and deleting it and try again.

    You could log in as a different user on the machine an invoke the sharing app. That should also allow you to sign in anew.

    /Steve


    Steve L [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.

    Wednesday, January 27, 2016 1:14 PM
  • I have seen mixed results when doing this, and it isn't supported, but you might try adding registry overrides for your Azure RMS server. Otherwise your local ADRMS service connection point will be detected.

    These are the overrides:

    HKLM\Software\Microsoft\MSIPC\ServiceLocation\EnterpriseCertification

    REG_SZ: default

    Value: https://Your_Azure_RMS_Cluster_Name/_wmcs/Certification>

    HKLM\Software\Microsoft\MSIPC\ServiceLocation\EnterprisePublishing

    REG_SZ: default

    Value: https://Your_Azure_RMS_Cluster_Name/_wmcs/Licensing>

    Then clear these

    rmdir
    %localAppData%\Microsoft\MSIPC /S /Q

    Reg delete
    "HKEY_CURRENT_USER\Software\Classes\Local
    Settings\Software\Microsoft\MSIPC" /f

    Reg delete
    "HKEY_CURRENT_USER\Software\Classes\Microsoft.IPViewerChildMenu" /f


    Friday, January 29, 2016 3:35 PM