none
Skeleton tracking not working ? RRS feed

  • Question

  • Hi,

    I'm trying to use some partner code that is using the SDK in c++. We have a weird problem where she is getting skeleton tracked without any problem, but on my machine all the skeleton get the positionOnly tracking status.

    The kinect initialisation is done like this :

            hr= NuiInitialize(NUI_INITIALIZE_FLAG_USES_SKELETON| NUI_INITIALIZE_FLAG_USES_DEPTH_AND_PLAYER_INDEX |NUI_INITIALIZE_FLAG_USES_COLOR);

    Then :

    HRESULT hr = NuiSkeletonGetNextFrame( 0, &SkeletonFrame );
    always return 0, which seems ok. But the skeletonFrame contains only "positionOnly" skeletons. Whatever the distance I'm from the sensor. I tried increasing the timeout value to 500ms without any change.

    I tried both with 1.5 and 1.6 SDKs.

    Do you have any idea where that could come from ? 

    Tuesday, February 5, 2013 5:15 PM

All replies

  • Have you tried making sure you Kinect is getting the proper power. Kinect's need a certain amount of power to return data correctly. I have this sometimes happen on my older computer at the office.


    Once you eliminate the impossible, whatever remains, no matter how improbable, must be the truth. - "Sherlock holmes" "speak softly and carry a big stick" - theodore roosevelt. Fear leads to anger, anger leads to hate, hate leads to suffering - Yoda. Blog - http://www.computerprofessions.co.nr

    Wednesday, February 13, 2013 8:08 PM