none
VS 2017 IDE Left Shifting My Comments

    Question

  • I have just installed VS 2017 and am now using it to continue developing a VB application I started in VS 2013 and continued in VS 2015.

    My brain struggles to handle comments interspersed with code so I have always done code down the left with small indents and comments to the right of the code by tabbing to about half way across the coding pane before entering the comment. This works for me and I haven't had a problem with it before.

    With VS 2017 if I insert a new line of code and if the next line below is a comment it removes all the tabs of that line so that the comment starts at column 1. If I reinsert the tabs then as soon as I move off that line it removes them for me. I am finding this extremely unhelpful and frustrating. Can someone let me know how to stop it.

    TIA


    Monday, March 20, 2017 1:35 PM

Answers

  • Found the solution.

    Tools / Options / Text Editor / Basic / Advanced.

    Uncheck "Pretty Listing of Code" option.

    • Marked as answer by njl111 Monday, March 20, 2017 5:40 PM
    Monday, March 20, 2017 5:40 PM