none
Cmdkey Error 1312

Answers

  • This can be because the "Do not allow storage of credentials or .NET Passports for network authentication" Network access policy is enabled on your machine. 

    Follow the steps below to disable the policy, then run the cmdkey command and try to mount file share with stored credentials.

    Steps:
    1. On the Management Server, click Start, click Run, type gpedit.msc, and then click OK.
    2. Under Computer Configuration, expand Windows Settings, expand Security Settings, expand Local Policies, and then expand Security Options.
    3. In the Policy pane, right-click Network access: Do not allow storage of credentials or .NET Passports for network authentication, click Properties, click Disabled, and then click OK.

    Reference: https://support.microsoft.com/en-us/kb/968264

    Wednesday, March 9, 2016 10:53 PM

All replies

  • To give a little more detail, I'm really interested in moving our small company's files to Azure Storage and having our users access them via mapped drives just like they do currently on our (outdated) file server. I would like to move away from local storage as well as have access to the files anywhere without synchronizing via OneDrive and other similar services. I can map the drive all day long by using the net use command with the username and the access key, but then it goes away after a reboot. The URL I posted above shows that one can make this persist by using cmdkey to store the credentials, but it does not work and gives the error "System error 1312 has occurred. A specified logon session does not exist. It may already have been terminated."
    Wednesday, March 9, 2016 2:42 PM
  • This can be because the "Do not allow storage of credentials or .NET Passports for network authentication" Network access policy is enabled on your machine. 

    Follow the steps below to disable the policy, then run the cmdkey command and try to mount file share with stored credentials.

    Steps:
    1. On the Management Server, click Start, click Run, type gpedit.msc, and then click OK.
    2. Under Computer Configuration, expand Windows Settings, expand Security Settings, expand Local Policies, and then expand Security Options.
    3. In the Policy pane, right-click Network access: Do not allow storage of credentials or .NET Passports for network authentication, click Properties, click Disabled, and then click OK.

    Reference: https://support.microsoft.com/en-us/kb/968264

    Wednesday, March 9, 2016 10:53 PM
  • Thank you for this suggestion. However, this setting was already set to Disabled. Do you have other suggestions?
    Thursday, March 10, 2016 1:08 PM