none
Hyper-V virtual NIC not allowing "Client for Microsoft Network" RRS feed

  • Question

  • I have Hyper-V role enabled on a Win2k8 standard machine but find that the virtual NIC that is created does not have "Client for Microsoft Network" enabled and due to this, I am not able to mount shares or access filesystems via UNC.

    When I try to check and enable the Client for Microsoft Network I get a message telling me that the action that I will be taking will disable Client for Microsoft Network which is exactly what I am trying NOT to do.

    At least one other person out in the intarwebs has had this issue from my searches:

    http://sqlsolace.blogspot.com/2008/04/windows-2008-networking.html

    Any solution to this other than uninstalling all the protocols for the interface, rebooting and re-installing?

    The issue does not occur with an Internal network type, only External.

    Thanks!
    Monday, July 28, 2008 4:55 AM

All replies

  • Networking with Hyper-V might not be what you initially expect in terms of what is bound to the physical and virtual network card.

     

    There is a virtual switch that is created inside the machines, and the virtual network cards in the VM's are 'connected' through the virtual switch both to each other, and the outside world.

     

    There's been some excellent stuff on this posted in blogs such as John Howard's blog and Ben Armstrong'sblog and I would STRONGLY recommend you read them before you embark on trying to change the bindings on any virtual NIC's

     

    If the info there doesn't solve your problem it would be good to have details such as how many physical NIC's in the system, how many virtual networks, and how things are 'connected'

    • Proposed as answer by jaonlsch23 Friday, June 13, 2014 5:43 PM
    Wednesday, August 6, 2008 10:07 PM
  • I followed the steps as shown at John Howards blog post you linked to and everything is the same except at the final step.

    His image shows all the MS protocols being bound to the virtual NIC:

    http://blogs.technet.com/blogfiles/jhoward/WindowsLiveWriter/HowdoesbasicnetworkingworkinHyperV_B633/8_2.jpg

    Mine is almost the same except "Client for Microsoft Networks" is not bound and any attempts to bind yields the response of "Your current selection will also disable the following features: Client for Microsoft Networks" which doesn't make any sense as I *AM* trying to get Clients for Microsoft Networks working.

    Here is the basic layout on my laptop (it isn't the normal run of the mill laptop, it's a quad Xeon 2.83 GHz with RAID5):

    1 100/1000 wired Gigabit NIC
    1 Wireless NIC (which we'll ignore as I cannot bind to it with Hyper-V)

    It's a pretty simple setup.

    In the steps I created a virtual NIC and everything works as expected. My physical NIC is only bound to the virtual switch, as expected. The new virtual NIC has everything checked except for virtual switch (as it should be) and Client for Microsoft Networks (which is not expected).

    So, with Hyper-V up and running with an external network configured I cannot hit network shares from the host Win2k8. Not good news. I've seen some blog entries of other folks that have seen this problem (in my original post) and it's pretty annoying and I don't want to go through the process of uninstalling all protocols and installing them one by one.

    Any ideas?

    Thanks.
    • Proposed as answer by Firehouse IT Monday, October 24, 2011 8:36 PM
    • Unproposed as answer by Firehouse IT Monday, October 24, 2011 8:36 PM
    Thursday, August 14, 2008 4:17 PM
  • I found a solution. I came across this blog entry (located at http://www.expta.com/2008/03/getting-networking-to-work-in-hyper-v.html) that assisted me.

    I blew away my virtual NIC with the Hyper-V manager and then unbound the physical NIC from all protocols and then re-created the virtual NIC with Hyper-V manager and lo and behold! A virtual NIC that has Client for Microsoft Networks!

    I bounced my machine and all appears to be well. The Host OS can connect to shares and the guest OS can have access to the external network as well. Yay!
    Thursday, August 14, 2008 6:58 PM
  • glad to hear you got a resolution to this. 

     

     

    As an aside I've noted that the MS Technet formus for virtualization seem a lot more active and are likely a better place to find help for hyper-v issues.

     

     

    Thursday, August 14, 2008 7:30 PM
  • A client of mine had Server 2008 with a Hyper-V virtual Server 2003 64bit.

     

    I was able to solve this for a client of mine by simply uninstalling each nic that had the problem through Hardware manager and then scanning for new hardware and reinstalling the nic.  My problem occured after bridging the nics and then trying to get Server 2003 to recognize the bridged nic through Hyper-V.  Hope this helps.

    Thursday, December 4, 2008 11:58 PM
  • This worked for me as well, Thank you very much.
    Wednesday, August 26, 2009 1:12 PM
  • Apologies for digging up an old thread.  Someone else might find this useful.  I've experienced the same issue where I can't enable the Client for Microsoft Networks on the virtual NIC.  The solution I found was to:

    1. Go to the "Network Connections" window in explorer
    2. Press the ALT key to display the menu bar
    3. On the menu bar click AdvancedAdvanced Settings...
    4. I selected the virtual NIC (Local Area Conection 4 for me) and noticed that Client for Microsoft Networks was unchecked for that NIC.  I checked the Client for Microsoft Networks check box and also the two check boxes under it for IPv4 and IPv6. 
    The approach above worked when attempting to check Client for Microsoft Networks via the NIC's properties dialog box did not work. 
    • Proposed as answer by Simon Dean Sunday, January 3, 2010 10:05 PM
    Sunday, January 3, 2010 10:05 PM
  • Simon, Your Solution was the best. Solved the problem simple as that (just yor 4 steps). thank you.
    Tuesday, January 19, 2010 11:02 PM
  • Brilliant, thank you Simon, this worked for me too!

     

    rich

    Wednesday, June 16, 2010 6:05 PM
  • Thx Simon, that did the trick here too.

    Another one of Microsoft's "undocumented features"...

    t.

    Thursday, July 15, 2010 8:12 PM
  • Genial, marvelous Simon. Thank very much! 

    Carlos

    Wednesday, July 25, 2012 8:27 PM
  • Thanks Simon, saved me an evening on site sorting the server out!
    Thursday, February 7, 2013 10:26 AM