none
How to relax validation on 837 schema RRS feed

  • Question

  • We have trading partners sending 837 files without certain segments or with incomplete segments.  The segments with missing data are not required for us and not worth rejecting the file and waiting for the client to fix.  Is there a way to relax the rules without turning validation completely off?  I have attempted to edit the settings on the failing segments with no avail. 

    For example:  The HI_OccurrenceInformation_TS837Q3_2300 loop would be supplied with only the H1_01:01 & H1_01:02 while H1_01:03 & H1_01:04 are required.  Regardless of what was changed in the settings, I could not get the validation to skip over the two segments.

    Tuesday, March 23, 2010 9:18 PM

Answers

  • Hi,

        edi Disaasembler works according to schema deployed. So all the nobs for Payload validation is in schema. The only way is to change the schema and make that required element min occurs to Zero and then redeploy schema, restart Biztalk host instance. Then edi disassembler can only ignore it.

     

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    Wednesday, March 24, 2010 2:17 AM
  • There are two ways to do this. The first is on the trade agreement where you can set up extended validation to false. Just uncheck it. The next is on the recieve location. Click on the elipses and take out validation. Other than that you would have to modify the schema but then I strongly do not recomend that because diagnosis codes is not something I would leave out of validation. If this is a trade partner specific thing you like ot do, copy the 4010X098A1 schema into a new name space and then assign it to that trade partner. Then you can have a custom complaince check for that trade partner.
    Please Indicate "Mark as Answer" if this Post has Answered the Question
    Wednesday, March 24, 2010 5:11 PM

All replies

  • Hi,

        edi Disaasembler works according to schema deployed. So all the nobs for Payload validation is in schema. The only way is to change the schema and make that required element min occurs to Zero and then redeploy schema, restart Biztalk host instance. Then edi disassembler can only ignore it.

     

     

    Thanks

    Gyan


    If this answers your question, please mark it as "Answered".
    Wednesday, March 24, 2010 2:17 AM
  • There are two ways to do this. The first is on the trade agreement where you can set up extended validation to false. Just uncheck it. The next is on the recieve location. Click on the elipses and take out validation. Other than that you would have to modify the schema but then I strongly do not recomend that because diagnosis codes is not something I would leave out of validation. If this is a trade partner specific thing you like ot do, copy the 4010X098A1 schema into a new name space and then assign it to that trade partner. Then you can have a custom complaince check for that trade partner.
    Please Indicate "Mark as Answer" if this Post has Answered the Question
    Wednesday, March 24, 2010 5:11 PM