locked
Kinect, WASAPI and Automatic Gain Control.... RRS feed

  • Question

  • I have been sampling my sound from the Kinect microphone array using the WASAPI.
    Now I have noticed that it applies some kind of Automatic Gain Control to the signal that is captured. Is there any way to turn it off? via the property store or the topology? (like on DMOs)

    Because the resulting fade that is created when the gain is faded back up again is creating problems for me.

    EDIT: I have done some more recordings and it sometimes really messes up my audio signal by increasing the gain so much that it starts clipping....

     

    Unfortunately this forum does not let me attach my sound file...

     


    • Edited by DrEvilD Wednesday, October 19, 2011 1:03 PM
    Wednesday, October 19, 2011 12:17 PM

Answers

All replies

  • Sorry, there is no way to control the raw signal obtained from WASAPI. The DMO settings like Automatic Gain Control are controlled at a software layer above the raw signal coming from the microphone.

    Eddy


    I'm here to help
    Friday, October 21, 2011 2:09 AM
  • Is there a way to obtain the raw signal of the Kinect without any pre-processing?

    Friday, October 21, 2011 8:34 AM
  • the WASAPI signal is what we get from the driver, and there is no way at the moment to configure the driver to output different kinds of signals. We are already tracking a request to add this kind of functionality (from http://social.msdn.microsoft.com/Forums/en-US/kinectsdkaudioapi/thread/8e2823d5-accf-4999-8367-8719c31d2448), but unfortunately I can't guarantee if/when we would fix this in a released product.

    Sorry about that.
    Eddy


    I'm here to help
    • Marked as answer by DrEvilD Friday, October 28, 2011 7:44 AM
    Friday, October 21, 2011 6:20 PM