none
VS2010 can't find references on win7 64bit? RRS feed

  • Question

  • System: win7 Sp1 64bit 

    VS: Visual Studio 2010 SP1

    Office: Office 2007 SP3 32bit

     

    When I tried to create a new VSTO Excel workbook project, VS2010 can't find references of "Microsoft.Office.Tools.Common.v4.0.Utilities.dll" and "Microsoft.Office.Tools.Excel.v4.0.Utilities.dll", then the new project could not be built. In fact, these two files are in the folder "C:\Program Files\Reference Assemblies\Microsoft\VSTO40\v4.0.Framework", VS2010 just can't find them automaticly.

    This won't happen if I use Win7 32bit, so I think maybe VS2010 tried to find them in "Program Files (x86)\Reference Assemblies"

    Tuesday, November 15, 2011 9:53 AM

Answers

  • Hi yangmijun,

     

    Thanks for posting in the MSDN Forum.

     

    I noticed that the “Office 2007 SP3” is a very new service pack. I’m wounding whether this service pack recovered some of the assemblies or setting to lead Visual Studio 2010 can’t create VSTO project correctly. I would recommend you repair your Visual Studio to see whether your Visual Studio can create project correctly after repair.

     

    I hope what I said can help you.

     

    Have a good day,

     

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, November 17, 2011 7:00 AM
    Moderator