locked
application for windows xp ? RRS feed

  • Question

  • Hello !

    is possible to create application for windows xp on visual studio 2013 ?

    i need to create an application that use sql server express and entity framework but i want to be compatible with windows xp.

    Thank you .

    Wednesday, February 5, 2014 3:21 PM

Answers

  • If you're not sure which service packs your XP users have installed, then you need to target 2.0.

    If you know your XP users have SP2, then you can target 3.5.

    If you know your XP users have SP3, then you can target 4.0.


    Convert between VB, C#, C++, & Java (http://www.tangiblesoftwaresolutions.com)
    Instant C# - VB to C# Converter
    Instant VB - C# to VB Converter

    • Proposed as answer by IronRazerz Wednesday, February 5, 2014 4:24 PM
    • Marked as answer by Leo (Apple) Yang Wednesday, February 12, 2014 5:53 AM
    Wednesday, February 5, 2014 4:23 PM

All replies

  • Certainly.  Just target .NET Framework 2.0.


    Convert between VB, C#, C++, & Java (http://www.tangiblesoftwaresolutions.com)
    Instant C# - VB to C# Converter
    Instant VB - C# to VB Converter

    Wednesday, February 5, 2014 4:01 PM
  • Thank you !

    But as i know windows xp support Net framework 4.0

    Wednesday, February 5, 2014 4:10 PM
  • If you're not sure which service packs your XP users have installed, then you need to target 2.0.

    If you know your XP users have SP2, then you can target 3.5.

    If you know your XP users have SP3, then you can target 4.0.


    Convert between VB, C#, C++, & Java (http://www.tangiblesoftwaresolutions.com)
    Instant C# - VB to C# Converter
    Instant VB - C# to VB Converter

    • Proposed as answer by IronRazerz Wednesday, February 5, 2014 4:24 PM
    • Marked as answer by Leo (Apple) Yang Wednesday, February 12, 2014 5:53 AM
    Wednesday, February 5, 2014 4:23 PM
  • @Dave

    Entitity framework with Framework 2.0?

    I think you made a typo.


    Success
    Cor

    Wednesday, February 5, 2014 4:25 PM
  • my users have xp sp3 so i target Net 4.0.

    But which version of entity framework support windows xp ?

    thank you.

    Wednesday, February 5, 2014 4:28 PM
  • @Dave

    Entitity framework with Framework 2.0?

    I think you made a typo.


    Success
    Cor


    See my second post.

    Convert between VB, C#, C++, & Java (http://www.tangiblesoftwaresolutions.com)
    Instant C# - VB to C# Converter
    Instant VB - C# to VB Converter

    Wednesday, February 5, 2014 4:36 PM
  • It's not a matter of which version of entity framework supports xp - it's a matter of which .NET framework version supports entity framework - once you have that and the XP users have the right service pack you're ready to go (but I don't think any XP service pack will allow .NET 4.5).


    Convert between VB, C#, C++, & Java (http://www.tangiblesoftwaresolutions.com)
    Instant C# - VB to C# Converter
    Instant VB - C# to VB Converter

    Wednesday, February 5, 2014 4:38 PM
  • my users have xp sp3 so i target Net 4.0.

    But which version of entity framework support windows xp ?

    thank you.


     Unless you know for a fact that they all have 4.0 installed i would target 2 or 3.5 to be safe. You could also require them to upgrade to whatever version you target. I am running XP Pro SP3 and i have only installed 3.5 so it is not a sure thing that they will have 4.0 installed just because they have Sp3.  :)
    Wednesday, February 5, 2014 4:39 PM
  • my users have xp sp3 so i target Net 4.0.

    But which version of entity framework support windows xp ?

    thank you.


     Unless you know for a fact that they all have 4.0 installed i would target 2 or 3.5 to be safe. You could also require them to upgrade to whatever version you target. I am running XP Pro SP3 and i have only installed 3.5 so it is not a sure thing that they will have 4.0 installed just because they have Sp3.  :)
    Right - if you're not going to install the .NET Framework, then better to play it safe.

    Convert between VB, C#, C++, & Java (http://www.tangiblesoftwaresolutions.com)
    Instant C# - VB to C# Converter
    Instant VB - C# to VB Converter

    Wednesday, February 5, 2014 5:58 PM
  • Hello !

    is possible to create application for windows xp on visual studio 2013 ?

    i need to create an application that use sql server express and entity framework but i want to be compatible with windows xp.

    Thank you .


    Entity Framework version history

    Please BEWARE that I have NO EXPERIENCE and NO EXPERTISE and probably onset of DEMENTIA which may affect my answers! Also, I've been told by an expert, that when you post an image it clutters up the thread and mysteriously, over time, the link to the image will somehow become "unstable" or something to that effect. :) I can only surmise that is due to Global Warming of the threads.

    Wednesday, February 5, 2014 7:37 PM