locked
IIS 6.0 No process is on the other end of the pipe. RRS feed

  • Question

  • User2106178394 posted

    Hello

    w2k3 server iis 6.0 / php 5.1.6

    php was working fine, but I read about fastcgi and thought I would give it a go...

    i removed existing php/iis install stuff (application extension etc)

    Installed fastcgi

    Everything worked, but I noticed that none of my apps that need write permissions to wwwroot were working (moodle for example has a data folder)

    I then gave NETWORK SERVICE write permissions to these folders and it worked

     

    I then noticed the fastcgi.impersonate line in php.ini and set it to "1"

    This resulted in:

     

    FastCGI Handler Extension

     


    Error 0x800700e9 occurred processing request.

    No process is on the other end of the pipe.

     

    This error occurs when trying to view ANY php file

    I have several apps that need write permissions and have read that impersonate is supposed to work with php 5.x - I don't want to have to change permissions

    I tried giving Everyone Full Control to c:\php5 (temporarily) and no help. 

    Any ideas? 
     


     

    Thursday, May 3, 2007 12:15 PM

All replies

  • User-679828332 posted

    Hi Mang,

    There were bugs in the PHP 4 and 5 impersonation code. They have been fixed. PHP 5.2.1 onwards should work.

    Cheerz,

    Rick.

    Thursday, May 3, 2007 12:19 PM
  • User2106178394 posted

    Thanks for your reply - I renamed my original php5 folder, created a new one and extracted the latest 5.2.x branch into it.

    I renamed the php.ini.recommend to php.ini, and pointed the dir_ext to my ext folder.

    I uncommented fastcgi.impersonate

    again gave "everyone" full control 

    reinstalled pear

    uninstalled fastcgi  / reinstalled fastcgi
     

     

    Now I get:

     

    FastCGI Handler Extension


    Error 0xc0000005 occurred processing request.

    The FastCGI process exited unexpectedly

     

    This again occurs on any php file - including a simple hello world.

     

    Thanks!
     

    Thursday, May 3, 2007 12:51 PM
  • User-679828332 posted

    Hi Mang,

    What happens if you try run your simple hello world from the command line? e.g. d:\php\php.exe helloworld.php.

    Thanks,

    Rick.

    Thursday, May 3, 2007 3:43 PM
  • Thursday, June 9, 2011 3:44 AM