none
Map rendering on slow netwroks RRS feed

  • Question

  • Hello I am using the

    Bing map AJAX Control : 7.0.20140318165546.99.

    On a slow connection I see that tiles don't load completely even if the tiles are coming back in http request. This leads to a situation when some tiles show up and some don't.

    I read somewhere that there is timeout ( 12 requests are made in batch and expected to come back in 5 secs) if they don't the request is timed out.

    Is there an optimization we can do handle the situations when the tiles are being loaded on slow connections?

    thanks

    neeraj


    Neeraj Sr

    Thursday, June 5, 2014 6:33 PM

Answers

  • This is happening as the tile layers automatically hide any images that do not load within a specified amount of time. This is done on purpose and is not a bug. We don't normally run into issues with slow internet connections. One thing you can try to do is reduce the number of tiles that are loaded at a time. To do this add the following code to your app before loading the map:


      Microsoft.Maps.maxConcurrentTileDownloads = 6;


    http://rbrundritt.wordpress.com

    Thursday, June 5, 2014 7:03 PM
  • This can be done like so: Microsoft.Maps.Globals.defaultTileSize = 128;

    However this makes no real difference in size as the resolution of the tile increases. This is mainly done to handle high resolution screens on mobile devices.

    All this said, the issue you are describing is very rare. So much so your the first person to mention this in a long time.


    http://rbrundritt.wordpress.com

    Friday, June 13, 2014 8:34 AM
  • You are likely looking at the request header rather than the response header. If you look at the response header you will see that that the map tiles are cached automatically already.

    http://rbrundritt.wordpress.com

    Sunday, June 15, 2014 5:35 PM

All replies

  • This is happening as the tile layers automatically hide any images that do not load within a specified amount of time. This is done on purpose and is not a bug. We don't normally run into issues with slow internet connections. One thing you can try to do is reduce the number of tiles that are loaded at a time. To do this add the following code to your app before loading the map:


      Microsoft.Maps.maxConcurrentTileDownloads = 6;


    http://rbrundritt.wordpress.com

    Thursday, June 5, 2014 7:03 PM
  • thanks ricky

    One of the options we want to try is to request tiles of smaller size. currently we are getting 256x256 size tiles.
    I believe there is mobile version of the tiles which are 64x64 . how do you request tiles of smaller size?

    the UI is a tablet device.

    thanks

    neeraj


    Neeraj Sr

    Thursday, June 12, 2014 10:47 PM
  • This can be done like so: Microsoft.Maps.Globals.defaultTileSize = 128;

    However this makes no real difference in size as the resolution of the tile increases. This is mainly done to handle high resolution screens on mobile devices.

    All this said, the issue you are describing is very rare. So much so your the first person to mention this in a long time.


    http://rbrundritt.wordpress.com

    Friday, June 13, 2014 8:34 AM
  • thanks Ricky for your help so far. probably the last question i have is related to caching. we see that the control is making a GET request for the map tiles with cache-control header set to no- cache. Can this behavior be changed.

    We are looking to see if caching can improve some of the latency. We don't see the tiles getting cached at all despite us sending cache-control:public headers.

    thanks

    neeraj


    Neeraj Sr

    Sunday, June 15, 2014 4:35 PM
  • You are likely looking at the request header rather than the response header. If you look at the response header you will see that that the map tiles are cached automatically already.

    http://rbrundritt.wordpress.com

    Sunday, June 15, 2014 5:35 PM