locked
Windows Audio Service won't start

    Question

  • I installed the Windows 8 developer preview on a Dell Latitude D600 and installed the SigmaTel C-Major audio drivers for the hardware and I can't get any audio. I used the troubleshooter and it states that the windows audio service won't start. When I start the Windows Audio service manually, it give me an error 1297. I checked the device manager and the driver is installed and it is working correctly. I tried looking for a compatible win 7 driver to see if that works however, I can't find one.

     

    I'm thinking this laptop is too old for Windows 8 however, there should be a solution somewhere so I can have audio on this D600.

    Wednesday, September 21, 2011 8:44 PM

Answers

  • Hello mim122,

    Since you are getting error 1297, we need to check if the Windows Audio Service Local Service account has the correct privileges.
    To resolve this problem, make sure that the SERVICE account includes the Create Global Objects policy.

    On the Start page, type in Services.msc.
    Go to Windows Audio.
    Under the Log on Tab: It should be set to Log on as: This account - Local Service

    Then go to Local Security Policy.
    Go to Control Panel, click on administrative Tools. Click on Local Security Policy.
    Expand Local Policies
    Click on User Rights Assignment. On the right pane, scroll to Create Global Objects.
    Verify if LOCAL SERVICE is listed under this user right. If not, double click and select Add User or Group.
    Type in LOCAL SERVICE.
    Click OK.

    Reboot.
    Now try again and see if you can start the Windows Audio Service.

    If still not working, check to see what privileges the Local Service account are enabled and list them for us.
    Let us know if this helps.



    Marilyn
    Tuesday, October 25, 2011 11:49 PM
    Moderator
  • Firstly , please follow steps in:

    http://social.technet.microsoft.com/wiki/contents/articles/troubleshoot-compatibility-issues-in-windows-8-developer-preview.aspx

    If you already done some steps , then ignore them and proceed with next one.

    Since it is most likely compatibility issue, I suggest post more detail about your device including manufacturer , model, etc. You could find them in device manager by view propertise of device and post here and Windows Compatibility team would check it.

    Tuesday, October 25, 2011 9:08 AM
  • Thanks Marilyn and Cyber_Defend_Team for your help. After a few days of trying different things (suggested in this forum), I decided to re-image the D600. I do not know what happened when I first imaged it but I suspect the hardd drive had an XP image on it and maybe that had something to do with the local service issue. This time, I wiped the drive clean and re-installed the Developers preview cleanly. I have audio now.

     

    Many thanks to all who suggested answers.

     

    Rick

     

     

    Monday, October 31, 2011 5:33 PM

All replies

  • Error 1297 means that the service permissions are damaged:

    //
    // MessageId: ERROR_INCOMPATIBLE_SERVICE_PRIVILEGE
    //
    // MessageText:
    //
    // A privilege that the service requires to function properly does not exist in the service account configuration.
    // You may use the Services Microsoft Management Console (MMC) snap-in (services.msc) and the Local Security Settings MMC snap-in (secpol.msc) to view the service configuration and the account configuration.
    //
    #define ERROR_INCOMPATIBLE_SERVICE_PRIVILEGE 1297L


    "A programmer is just a tool which converts caffeine into code"

    Wednesday, September 21, 2011 10:15 PM
  • On the Start page, type in Services.msc.
    Go to Windows Audio.
    Check to see if the Startup type is set to Automatic and the Service Status is running.

    Under the Log on Tab:
    It should be set to Log on as: This account
    Local Service

    Go to Windows Audio Endpoint Builder.
    Check to see if the Startup type is set to Automatic and the Service Status is running.

    Under the Log on Tab:
    It should be set to Log on as: Local System account. 

    Let us know if these options are different on your computer.


    Marilyn
    Wednesday, September 28, 2011 2:02 AM
    Moderator
  • I know this thread is month old, but I am in the same boat, and Marilyn.. I did what you suggested, but I get error code 1297 when I try to  start windows audio service. Tried updating drivers etc.. uninstalling & reinstalling device, etc.

    Thanks!

    Tuesday, October 25, 2011 4:03 AM
  • Firstly , please follow steps in:

    http://social.technet.microsoft.com/wiki/contents/articles/troubleshoot-compatibility-issues-in-windows-8-developer-preview.aspx

    If you already done some steps , then ignore them and proceed with next one.

    Since it is most likely compatibility issue, I suggest post more detail about your device including manufacturer , model, etc. You could find them in device manager by view propertise of device and post here and Windows Compatibility team would check it.

    Tuesday, October 25, 2011 9:08 AM
  • Hello mim122,

    Since you are getting error 1297, we need to check if the Windows Audio Service Local Service account has the correct privileges.
    To resolve this problem, make sure that the SERVICE account includes the Create Global Objects policy.

    On the Start page, type in Services.msc.
    Go to Windows Audio.
    Under the Log on Tab: It should be set to Log on as: This account - Local Service

    Then go to Local Security Policy.
    Go to Control Panel, click on administrative Tools. Click on Local Security Policy.
    Expand Local Policies
    Click on User Rights Assignment. On the right pane, scroll to Create Global Objects.
    Verify if LOCAL SERVICE is listed under this user right. If not, double click and select Add User or Group.
    Type in LOCAL SERVICE.
    Click OK.

    Reboot.
    Now try again and see if you can start the Windows Audio Service.

    If still not working, check to see what privileges the Local Service account are enabled and list them for us.
    Let us know if this helps.



    Marilyn
    Tuesday, October 25, 2011 11:49 PM
    Moderator
  • Thanks Marilyn and Cyber_Defend_Team for your help. After a few days of trying different things (suggested in this forum), I decided to re-image the D600. I do not know what happened when I first imaged it but I suspect the hardd drive had an XP image on it and maybe that had something to do with the local service issue. This time, I wiped the drive clean and re-installed the Developers preview cleanly. I have audio now.

     

    Many thanks to all who suggested answers.

     

    Rick

     

     

    Monday, October 31, 2011 5:33 PM
  • Hello, forgive my stupidity. I went through all the things you suggested. local service is listed under user rights. I rebooted, I re-installed, I am still getting 1297. What could be wrong? It was a working computer with XP and maybe I am having the same problem as pasandmanusa. I may also have made the mistake of re-installing the realtek driver when it was already there. Is there any new information?

     

    David


    David
    Friday, December 2, 2011 7:06 PM
  • Problem solved. You have got to install on a new drive. Picking up settings from previous XP sounds like a good idea but it causes so many problems. Now I am trying to put XP back on the original drive and that is proving harder lol! The W8 just went straight in no problems! I tried it on a laptop previously vista and that was no problem. One small bit of info: I have a dual screen. For some reason W8 defaults the second screen to 85Hz refresh and as soon as you set higher resolution you can get problems with some monitors. Best to default to 61
    David
    Saturday, December 3, 2011 2:04 PM