none
Visual Studio 11 remote kernel debugging - Can not install Driver Test Components RRS feed

  • Question

  • Hello,

    i'd like to configure a computer for Visual Studio 11 (customer preview) remote kernel debugging.

    Host Computer (Windows 7 Prof. SP1):
    - Visual Studio 11 (customer preview) (Running with Administrator Privileges)

    Target Computer (Windows 7 Prof. SP1):
    - I disabled UAC through the registry
    - I enabled the Administrator account and i'm logged in as Administrator
    - I disabled the firewall
    - I turn on network discovery and i turn on file and printer sharing.

    The host computer is able to ping the target computer and vise versa.

    In VS 11 is use the menu Driver->Test->Configure Computers to configure the target computer.

    The log message says: The network name can not be found.
    But the host computer creates the folder C:\DriverTest.

    Progress event: Current: 0, Max: -1, Message: "Connecting to computer "WIN-DDLSO47LAT3""
    Initialize: Computer: WIN-DDLSO47LAT3
    InstallComputer: Host Computer: andi-PC
    InstallComputer: Host Architecture: x86
    InstallComputer: Host 64bit Operating System: False
    InstallComputer: Host Operating System Version: 6.1.7601.65536
    InstallComputer: Process Administrator Privilege: True
    Progress event: Current: 1, Max: 19, Message: "Installing driver test automation service"
    [19:45:21:201]: Installing provisioning service
    Progress event: Current: 2, Max: 19, Message: "Getting computer system information"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Progress event: Current: 3, Max: 19, Message: "Copying driver test automation files"
    [19:45:27:298]: Der Netzwerkname wurde nicht gefunden.
    
    Progress event: Current: 3, Max: 19, Message: "Der Netzwerkname wurde nicht gefunden.
    "
    Progress event: Current: 3, Max: 19, Message: "Computer configuration log file://C:/Users/andi/AppData/Roaming/Microsoft/DriverTest/Install/Driver%20Test%20Computer%20Configuration%2020120314194511141.log"

    Therefore, I shared the C:\DriverTest folder with the following name DriverTest$ .

    Now, the host computer copies the installation files into the DriverTest folder.
    And the host computer creates a WDKRemoteUser user account.
    But he is not able to install the .NET4 and the other tools.

    Progress event: Current: 0, Max: -1, Message: "Connecting to computer "WIN-DDLSO47LAT3""
    Initialize: Computer: WIN-DDLSO47LAT3
    InstallComputer: Host Computer: andi-PC
    InstallComputer: Host Architecture: x86
    InstallComputer: Host 64bit Operating System: False
    InstallComputer: Host Operating System Version: 6.1.7601.65536
    InstallComputer: Process Administrator Privilege: True
    Progress event: Current: 1, Max: 19, Message: "Installing driver test automation service"
    Progress event: Current: 2, Max: 19, Message: "Getting computer system information"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Progress event: Current: 3, Max: 19, Message: "Copying driver test automation files"
    Progress event: Current: 4, Max: 19, Message: "Configuring automation user logon settings"
    Initialize: Computer: 
    Initialize: Computer: WIN-DDLSO47LAT3
    Initialize: Computer: 
    Start result group:
      Name: Install Driver Test Components
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestGroups\Install Driver Test Components.xml
      Computer: WIN-DDLSO47LAT3
    Initialize: Computer: 
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Progress event: Current: 5, Max: 19, Message: "Installing .NET Framework (possible reboot)"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Initialize: Computer: WIN-DDLSO47LAT3
    InternalRunTest: Host Computer: andi-PC
    InternalRunTest: Host Architecture: x86
    InternalRunTest: Host 64bit Operating System: False
    InternalRunTest: Host Operating System Version: 6.1.7601.65536
    InternalRunTest: Process Administrator Privilege: True
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    ExecuteProcess: Arguments: "%SystemDrive%\DriverTest\Run\dotNetFx40_Full_x86_x64.exe" /select:"@Name='Installing .NET Framework (possible reboot)'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_.NET_Framework_(possible_reboot)_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    [20:35:13:699]: [Installing .NET Framework (possible reboot)] Command Line:
    te.exe "%SystemDrive%\DriverTest\Run\dotNetFx40_Full_x86_x64.exe" /select:"@Name='Installing .NET Framework (possible reboot)'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_.NET_Framework_(possible_reboot)_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    Created new result:
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing .NET Framework (possible reboot) 00011.NET Framework (possible reboot)
      Log Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing .NET Framework (possible reboot) 00011.log
      Computer: WIN-DDLSO47LAT3
      Test Binary: %SystemDrive%\DriverTest\Setup\dotNetFx40_Full_x86_x64.exe
      Test Name:  Installing .NET Framework (possible reboot)
      Test Display Name: Installing .NET Framework (possible reboot)
    Initialize: Computer: 
    RemoteExecute: Binary: %SystemDrive%\DriverTest\Setup\dotNetFx40_Full_x86_x64.exe
    RemoteExecution: Arguments: /q /norestart /log %SystemDrive%\DriverTest\Logs\DotNetInstall.log
    RemoteExecute: Process creation return code: 2220
    RemoteExecute: Process exit code: 0
    Result completed
    Test process exit code: 2220
    Result status updated: Fail
    Initialize: Computer: 
    Initialize: Computer: 
    Progress event: Current: 5, Max: 19, Message: "A failure occurred running the configuration task"
    Progress event: Current: 6, Max: 19, Message: "Installing VC Redist (x86)"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Initialize: Computer: WIN-DDLSO47LAT3
    InternalRunTest: Host Computer: andi-PC
    InternalRunTest: Host Architecture: x86
    InternalRunTest: Host 64bit Operating System: False
    InternalRunTest: Host Operating System Version: 6.1.7601.65536
    InternalRunTest: Process Administrator Privilege: True
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    ExecuteProcess: Arguments: "%SystemDrive%\DriverTest\Run\vcredist_x86.exe" /select:"@Name='Installing VC Redist (x86)'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_VC_Redist_(x86)_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    [20:35:14:198]: [Installing VC Redist (x86)] Command Line:
    te.exe "%SystemDrive%\DriverTest\Run\vcredist_x86.exe" /select:"@Name='Installing VC Redist (x86)'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_VC_Redist_(x86)_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    Created new result:
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing VC Redist (x86) 00011.xml
      Log Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing VC Redist (x86) 00011.log
      Computer: WIN-DDLSO47LAT3
      Test Binary: %SystemDrive%\DriverTest\Setup\vcredist_x86.exe
      Test Name:  Installing VC Redist (x86)
      Test Display Name: Installing VC Redist (x86)
    Initialize: Computer: 
    RemoteExecute: Binary: %SystemDrive%\DriverTest\Setup\vcredist_x86.exe
    RemoteExecution: Arguments: /q
    RemoteExecute: Process creation return code: 2220
    RemoteExecute: Process exit code: 0
    Result completed
    Test process exit code: 2220
    Result status updated: Fail
    Initialize: Computer: 
    Progress event: Current: 6, Max: 19, Message: "A failure occurred running the configuration task"
    Initialize: Computer: 
    Progress event: Current: 7, Max: 19, Message: "Installing test automation (x86)"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Initialize: Computer: WIN-DDLSO47LAT3
    InternalRunTest: Host Computer: andi-PC
    InternalRunTest: Host Architecture: x86
    InternalRunTest: Host 64bit Operating System: False
    InternalRunTest: Host Operating System Version: 6.1.7601.65536
    InternalRunTest: Process Administrator Privilege: True
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    ExecuteProcess: Arguments: "%SystemDrive%\DriverTest\Run\msiexec.exe" /select:"@Name='Installing test automation (x86)'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_test_automation_(x86)_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    [20:35:14:728]: [Installing test automation (x86)] Command Line:
    te.exe "%SystemDrive%\DriverTest\Run\msiexec.exe" /select:"@Name='Installing test automation (x86)'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_test_automation_(x86)_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    Created new result:
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing test automation (x86) 00011.xml
      Log Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing test automation (x86) 00011.log
      Computer: WIN-DDLSO47LAT3
      Test Binary: msiexec.exe
      Test Name:  Installing test automation (x86)
      Test Display Name: Installing test automation (x86)
    Initialize: Computer: 
    Initialize: Computer: 
    RemoteExecute: Binary: msiexec.exe
    RemoteExecution: Arguments: /i "%SystemDrive%\DriverTest\Setup\Test Authoring and Execution Framework x86-x86_en-us.msi" /qb- KITSROOT="%ProgramFiles%\Windows Kits\8.0" KITTARGET=1 /l*v "%SystemDrive%\DriverTest\Logs\Test Authoring and Execution Framework x86-x86_en-us.msi_install.log"
    RemoteExecute: Process creation return code: 2220
    RemoteExecute: Process exit code: 0
    Result completed
    Test process exit code: 2220
    Result status updated: Fail
    Initialize: Computer: 
    Initialize: Computer: 
    Progress event: Current: 7, Max: 19, Message: "A failure occurred running the configuration task"
    Initialize: Computer: 
    Progress event: Current: 8, Max: 19, Message: "Installing debuggers (x86)"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Initialize: Computer: WIN-DDLSO47LAT3
    InternalRunTest: Host Computer: andi-PC
    InternalRunTest: Host Architecture: x86
    InternalRunTest: Host 64bit Operating System: False
    InternalRunTest: Host Operating System Version: 6.1.7601.65536
    InternalRunTest: Process Administrator Privilege: True
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    ExecuteProcess: Arguments: "%SystemDrive%\DriverTest\Run\msiexec.exe" /select:"@Name='Installing debuggers (x86)'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_debuggers_(x86)_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    [20:35:15:243]: [Installing debuggers (x86)] Command Line:
    te.exe "%SystemDrive%\DriverTest\Run\msiexec.exe" /select:"@Name='Installing debuggers (x86)'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_debuggers_(x86)_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    Created new result:
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing debuggers (x86) 00011.xml
      Log Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing debuggers (x86) 00011.log
      Computer: WIN-DDLSO47LAT3
      Test Binary: msiexec.exe
      Test Name:  Installing debuggers (x86)
      Test Display Name: Installing debuggers (x86)
    Initialize: Computer: 
    Initialize: Computer: 
    RemoteExecute: Binary: msiexec.exe
    RemoteExecution: Arguments: /i "%SystemDrive%\DriverTest\Setup\x86 Debuggers And Tools-x86_en-us.msi" /qb- /l*v "%SystemDrive%\DriverTest\Logs\x86 Debuggers And Tools-x86_en-us.msi_install.log"
    RemoteExecute: Process creation return code: 2220
    RemoteExecute: Process exit code: 0
    Result completed
    Test process exit code: 2220
    Result status updated: Fail
    Initialize: Computer: 
    Progress event: Current: 8, Max: 19, Message: "A failure occurred running the configuration task"
    Initialize: Computer: 
    Progress event: Current: 9, Max: 19, Message: "Installing driver test framework"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Initialize: Computer: WIN-DDLSO47LAT3
    InternalRunTest: Host Computer: andi-PC
    InternalRunTest: Host Architecture: x86
    InternalRunTest: Host 64bit Operating System: False
    InternalRunTest: Host Operating System Version: 6.1.7601.65536
    InternalRunTest: Process Administrator Privilege: True
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    ExecuteProcess: Arguments: "%SystemDrive%\DriverTest\Run\msiexec.exe" /select:"@Name='Installing driver test framework'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_driver_test_framework_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    [20:35:15:758]: [Installing driver test framework] Command Line:
    te.exe "%SystemDrive%\DriverTest\Run\msiexec.exe" /select:"@Name='Installing driver test framework'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Installing_driver_test_framework_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    Created new result:
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing driver test framework 00011.xml
      Log Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Installing driver test framework 00011.log
      Computer: WIN-DDLSO47LAT3
      Test Binary: msiexec.exe
      Test Name:  Installing driver test framework
      Test Display Name: Installing driver test framework
    Initialize: Computer: 
    RemoteExecute: Binary: msiexec.exe
    RemoteExecution: Arguments: /i "%SystemDrive%\DriverTest\Setup\Windows Driver Testing Framework (WDTF) Runtime Libraries-x86_en-us.msi" /qb- KITTARGET=1 /l*v "%SystemDrive%\DriverTest\Logs\Windows Driver Testing Framework (WDTF) Runtime Libraries-x86_en-us.msi_install.log"
    RemoteExecute: Process creation return code: 2220
    RemoteExecute: Process exit code: 0
    Result completed
    Test process exit code: 2220
    Result status updated: Fail
    Initialize: Computer: 
    Progress event: Current: 9, Max: 19, Message: "A failure occurred running the configuration task"
    Initialize: Computer: 
    Progress event: Current: 10, Max: 19, Message: "Registering logging components"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Initialize: Computer: WIN-DDLSO47LAT3
    InternalRunTest: Host Computer: andi-PC
    InternalRunTest: Host Architecture: x86
    InternalRunTest: Host 64bit Operating System: False
    InternalRunTest: Host Operating System Version: 6.1.7601.65536
    InternalRunTest: Process Administrator Privilege: True
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    ExecuteProcess: Arguments: "%SystemDrive%\DriverTest\Run\regsvr32.exe" /select:"@Name='Registering logging components'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Registering_logging_components_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    [20:35:16:304]: [Registering logging components] Command Line:
    te.exe "%SystemDrive%\DriverTest\Run\regsvr32.exe" /select:"@Name='Registering logging components'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Registering_logging_components_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    Created new result:
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Registering logging components 00011.xml
      Log Path: 
      Computer: WIN-DDLSO47LAT3
      Test Binary: regsvr32.exe
      Test Name:  Registering logging components
      Test Display Name: Registering logging components
    Initialize: Computer: 
    Initialize: Computer: 
    RemoteExecute: Binary: regsvr32.exe
    RemoteExecution: Arguments: /s %SystemDrive%\DriverTest\WTTLogcm.dll
    RemoteExecute: Process creation return code: 2220
    RemoteExecute: Process exit code: 0
    Result completed
    Test process exit code: 2220
    Result status updated: Fail
    Initialize: Computer: 
    Progress event: Current: 10, Max: 19, Message: "A failure occurred running the configuration task"
    Progress event: Current: 11, Max: 19, Message: "Configure kernel debugger settings"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Initialize: Computer: WIN-DDLSO47LAT3
    InternalRunTest: Host Computer: andi-PC
    InternalRunTest: Host Architecture: x86
    InternalRunTest: Host 64bit Operating System: False
    InternalRunTest: Host Operating System Version: 6.1.7601.65536
    InternalRunTest: Process Administrator Privilege: True
    Initialize: Computer: 
    Initialize: Computer: 
    Initialize: Computer: 
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    [20:35:16:632]: Removing any existing files from test execution folder
    ExecuteProcess: Arguments: "%SystemDrive%\DriverTest\Run\DriverTestTasks.dll" /select:"@Name='DriverTestTasks::_ConfigureKernelDebugger'" /p:"DebugTransport=SERIAL" /p:"SerialPortNumber=0" /p:"BaudRate=115200" /p:"StartPolicy=Active" /p:"IgnoreUserModeExceptions=0" /p:"SuppressReboot=1" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Configure_kernel_debugger_settings_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    [20:35:18:566]: [Configure kernel debugger settings] Command Line:
    te.exe "%SystemDrive%\DriverTest\Run\DriverTestTasks.dll" /select:"@Name='DriverTestTasks::_ConfigureKernelDebugger'" /p:"DebugTransport=SERIAL" /p:"SerialPortNumber=0" /p:"BaudRate=115200" /p:"StartPolicy=Active" /p:"IgnoreUserModeExceptions=0" /p:"SuppressReboot=1" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Configure_kernel_debugger_settings_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    Created new result:
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Configure kernel debugger settings 00011.xml
      Log Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Configure_kernel_debugger_settings_00011.wtl
      Computer: WIN-DDLSO47LAT3
      Test Binary: C:\Program Files\Windows Kits\8.0\Testing\Tests\X86\DriverTestTasks.dll
      Test Name:  DriverTestTasks::_ConfigureKernelDebugger
      Test Display Name: Configure kernel debugger settings
    Initialize: Computer: 
    Initialize: Computer: 
    RemoteExecute: Binary: $KitRoot$\Testing\Runtimes\TAEF\te.exe
    RemoteExecution: Arguments: "%SystemDrive%\DriverTest\Run\DriverTestTasks.dll" /select:"@Name='DriverTestTasks::_ConfigureKernelDebugger'" /p:"DebugTransport=SERIAL" /p:"SerialPortNumber=0" /p:"BaudRate=115200" /p:"StartPolicy=Active" /p:"IgnoreUserModeExceptions=0" /p:"SuppressReboot=1" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Configure_kernel_debugger_settings_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    RemoteExecute: Process creation return code: 2220
    RemoteExecute: Process exit code: 0
    Result completed
    Test process exit code: 2220
    Result status updated: Fail
    Initialize: Computer: 
    Progress event: Current: 11, Max: 19, Message: "A failure occurred running the configuration task"
    Initialize: Computer: 
    Progress event: Current: 12, Max: 19, Message: "Configure computer settings"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Initialize: Computer: WIN-DDLSO47LAT3
    InternalRunTest: Host Computer: andi-PC
    InternalRunTest: Host Architecture: x86
    InternalRunTest: Host 64bit Operating System: False
    InternalRunTest: Host Operating System Version: 6.1.7601.65536
    InternalRunTest: Process Administrator Privilege: True
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    [20:35:19:128]: Removing any existing files from test execution folder
    ExecuteProcess: Arguments: "%SystemDrive%\DriverTest\Run\DriverTestTasks.dll" /select:"@Name='DriverTestTasks::_ConfigureCommonSettings'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Configure_computer_settings_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    [20:35:21:265]: [Configure computer settings] Command Line:
    te.exe "%SystemDrive%\DriverTest\Run\DriverTestTasks.dll" /select:"@Name='DriverTestTasks::_ConfigureCommonSettings'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Configure_computer_settings_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    Created new result:
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Configure computer settings 00011.xml
      Log Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Configure_computer_settings_00011.wtl
      Computer: WIN-DDLSO47LAT3
      Test Binary: C:\Program Files\Windows Kits\8.0\Testing\Tests\X86\DriverTestTasks.dll
      Test Name:  DriverTestTasks::_ConfigureCommonSettings
      Test Display Name: Configure computer settings
    Initialize: Computer: 
    RemoteExecute: Binary: $KitRoot$\Testing\Runtimes\TAEF\te.exe
    RemoteExecution: Arguments: "%SystemDrive%\DriverTest\Run\DriverTestTasks.dll" /select:"@Name='DriverTestTasks::_ConfigureCommonSettings'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Configure_computer_settings_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    RemoteExecute: Process creation return code: 2220
    RemoteExecute: Process exit code: 0
    Result completed
    Test process exit code: 2220
    Result status updated: Fail
    Initialize: Computer: 
    Progress event: Current: 12, Max: 19, Message: "A failure occurred running the configuration task"
    Initialize: Computer: 
    Progress event: Current: 13, Max: 19, Message: "Creating system restore point"
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    Initialize: Computer: WIN-DDLSO47LAT3
    InternalRunTest: Host Computer: andi-PC
    InternalRunTest: Host Architecture: x86
    InternalRunTest: Host 64bit Operating System: False
    InternalRunTest: Host Operating System Version: 6.1.7601.65536
    InternalRunTest: Process Administrator Privilege: True
    Initialize: Computer: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Computer Name: WIN-DDLSO47LAT3
    GetMachinePropertiesFromService: Architecture: I386
    GetMachinePropertiesFromService: Operating System Version: 6.1.7600.0
    GetMachinePropertiesFromService: Domain Joined: False
    ExecuteProcess: Arguments: "%SystemDrive%\DriverTest\Run\cscript.exe" /select:"@Name='Creating system restore point'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Creating_system_restore_point_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    [20:35:21:764]: [Creating system restore point] Command Line:
    te.exe "%SystemDrive%\DriverTest\Run\cscript.exe" /select:"@Name='Creating system restore point'" /rebootStateFile:%SystemDrive%\DriverTest\Logs\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Logs\Creating_system_restore_point_00011.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated
    Created new result:
      Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Creating system restore point 00011.xml
      Log Path: C:\Users\andi\AppData\Roaming\Microsoft\DriverTest\TestRepository\Results\Creating system restore point 00011.log
      Computer: WIN-DDLSO47LAT3
      Test Binary: cscript.exe
      Test Name:  Creating system restore point
      Test Display Name: Creating system restore point
    Initialize: Computer: 
    RemoteExecute: Binary: cscript.exe
    RemoteExecution: Arguments: %SystemDrive%\DriverTest\Setup\CreateRestore.js
    RemoteExecute: Process creation return code: 2220
    RemoteExecute: Process exit code: 0
    Result completed
    Test process exit code: 2220
    Result status updated: Fail
    Initialize: Computer: 
    Progress event: Current: 13, Max: 19, Message: "A failure occurred running the configuration task"
    Initialize: Computer: 
    [20:35:22:138]: Install Driver Test Components summary:
    [20:35:22:138]:   Installing .NET Framework (possible reboot): Fail
    [20:35:22:138]:   Installing VC Redist (x86): Fail
    [20:35:22:138]:   Installing test automation (x86): Fail
    [20:35:22:138]:   Installing debuggers (x86): Fail
    [20:35:22:138]:   Installing driver test framework: Fail
    [20:35:22:138]:   Registering logging components: Fail
    [20:35:22:138]:   Configure kernel debugger settings: Fail
    [20:35:22:138]:   Configure computer settings: Fail
    [20:35:22:138]:   Creating system restore point: Fail
    Result Group Completed: Fail
    Initialize: Computer: 
    Initialize: Computer: 
    Progress event: Current: 19, Max: 19, Message: ""
    Progress event: Current: 19, Max: 19, Message: "Computer configuration log file://C:/Users/andi/AppData/Roaming/Microsoft/DriverTest/Install/Driver%20Test%20Computer%20Configuration%2020120314203436609.log"

    I do not really know what's wrong.
    Can someone help me here!
    Thank you very much!


    Greetings,

    Fox-Dev



    • Edited by FoX-Dev Wednesday, March 14, 2012 7:50 PM
    • Moved by Jack Zhai-MSFTMicrosoft contingent staff Monday, March 26, 2012 2:35 AM It is related to the Windows Desktop Debugging. (From:Visual Studio Debugger)
    • Moved by Mr. Wharty Friday, June 1, 2012 1:14 AM (From:Off-Topic Posts (Do Not Post Here))
    Wednesday, March 14, 2012 7:47 PM

All replies

  • Hi, Online help specifies that only Windows 8 version can debug on network connections, you should use another connection type as usb or serial. Greetings.
    • Proposed as answer by Jia Xuan 2010 Monday, March 19, 2012 4:18 AM
    Thursday, March 15, 2012 6:55 PM
  • Hi Fox-Dev,

    I agree with Driverdep’s suggestion, for detailed information, see this blog Developing Device Drivers in Studio 11.

    Thanks,

    Xuan

    Friday, March 16, 2012 6:16 AM
  • Hello Driverdep, Jia Yuan 2010

    I've forgotten to mention that, the target computer runs on the host computer as a VM. I use the Connection Type Serial for Debugging. But to install the Debugging tools on the target computer the host computer uses the network connection, right?
    Greetings

    Friday, March 16, 2012 9:06 AM
  • I think you are right!!
    Monday, March 19, 2012 4:17 AM
  • Hi Fox-Dev,

    Did these replies resolve your problem?

    You could mark the answer if they did then I will close this thread, if not please post the latest situation of this issue.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Wednesday, March 21, 2012 3:01 AM
  • Hi Jack Zhai,

    i still have the same problem. VS11 is not able to install the debugging tools on the target computer.
    I have kept to the following instructions: Developing Device Drivers in Studio 11.Maybe it's the VM.
    Therefore, I now use WinDbg for the moment. However, I am still interested in a solution.

    Thanks!

    Greetings


    • Edited by FoX-Dev Thursday, March 22, 2012 8:42 PM
    Thursday, March 22, 2012 8:41 PM
  • Hi Fox-Dev,

    Glad to receive your reply.

    I did some research about this issue, but I still don’t find other better solution about this issue.

    Actually it is not a Visual Studio Debugger issue, it is related to Windows Desktop Debugging, my suggestion is that you could post this issue in the Windows Desktop Debugging forum for dedicated support. Thanks for your understanding.

    Have a nice day,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Friday, March 23, 2012 6:02 AM
  • I had the same issue using VS 2012 and WDK 8.0.
    Progress event: Current: 5, Max: 19, Message: "A failure occurred running the configuration task"
    Progress event: Current: 6, Max: 19, Message: "Installing VC Redist (x86)"

    What happens is that on the target machine, the VC Redist is uploaded on:
    %SystemDrive%\DriverTest\Setup\I386\vcredist_X86.exe
    but the provisioning tool wants to install the component using:
    %SystemDrive%\DriverTest\Setup\x86\vcredist_X86.exe
    Of course the file is not found (I386 vs x86 directory).

    After the first try, just copy the vcredist_X86.exe to the x86 folder (which you have to create first).
    Next try, install will work and provisioning finishes OK.

    Hope this helps others with the same issue...


    • Edited by lper Monday, April 7, 2014 7:08 PM
    Monday, April 7, 2014 7:06 PM