none
Getting 'could not load file or assembly microsoft.dotnet.projectmodel when deploying to empty asp.net core project to azure

    Question

  • I installed VS 2015 Update 3 today, created a project based on 'asp.net core web application' template with Azure deployment option on. It builds and runs just fine on the local machine. However when I try publishing it to Azure it produces an error "Could not load file or assembly 'Microsoft.DotNet.ProjectModel".

    I'm using the publish option in VS. I'm getting the same error on all my projects that previously worked fine when I was using asp.net core RC2

    Just reinstalled VS, but no luck...

    Mike


    Mike

    Thursday, September 15, 2016 5:16 PM

Answers

  • Hi Mike,

    Please create another web application (not .NET Core application) and try publish to Azure to check whether this issue only occurs on .NET Core project type.

    If other project type also has this issue, I'm afraid that there has any problem on Visual Studio installation. Please try with following steps to troubleshoot this issue.

    1. Run Visual Studio in safe mode to make sure whether this issue caused by third part packages/extensions.
    2. Check whether your Visual Studio has installed the latest Update.
    3. Check the .NET Core version, whether it is the latest version.

    If it only occurs on .NET Core application, please refer to following thread, which has the similar issue with you.

    http://stackoverflow.com/questions/38512468/cant-publish-net-core-web-application-could-not-load-file-or-assembly-microso

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, September 16, 2016 9:43 AM
    Moderator