locked
Workflows stay 'In Progress' after reboot RRS feed

  • Question

  • User2011366442 posted

    Hi everyone,

    UPDATE (18/12/2013): I have this firing WFs now and they're persisting and completing but with the exception of when I reboot the VM I am running them off. Once I reboot, all current running WFs stay in the 'In-Progress' status and the 'Resume' option is greyed out in AppFabric IIS. Anyone have ideas or thoughts? Thanks

    I've setup a simple workflow which gets fired via a Web Form. The WF Service writes out a log of where it is in the process, so it writes a textfile once it is fired to simply let me know that it is running and working. Then I use the Delay Activity to put it to sleep for 'X' amount of time and after it comes out of that write another textfile. This works fine for short periods; minutes, hours etc. However, when I try for tens of hours or days the process timesout and does not fail nor complete. I've been into AppFabric to see if any extra information can be provided and it just lists it as 'In-Progress'. Is there something I am not doing right or a more 'correct' way to put workflows to sleep? The long term goal of this would be, for example, for a user to sign up to a service, firing a workflow, then every so often ('X' amount of time > Delay Activity) remind the user of other services they can get by upgrading.

    Persistence and Monitoring are both setup, I am using .NET 4.0 and IIS 7 with the AppFabric plugin. 

    If any information is required please ask and I'll do my best to provide it. Any help help is much appreciated. 

    Thanks,
    Daniel 

    P.S. There is no real code to show, as I am just using the built in Delay Activity, but I have attached an image of how the service looks in the design view.

    Service.xamlx

    Tuesday, December 3, 2013 5:28 AM

Answers

  • User2011366442 posted

    After a lot of researching I have found out why it hadn't been working. The initial thread I was referring to was good for info but essentially too old and out of date. Please refer to this article from the MSDN Website:

    http://msdn.microsoft.com/en-us/library/ee677285.aspx

    Essentially, I had all my sites and services, in IIS, set up as a "Web Site". When you goto the WCF & WF Configuration set up, inside it does not contain an option saying "Auto-Start". What you have to actually do is setup the Service as an "Application" under a Web Site in IIS. Once you set it up, return to the WCF and WF Configuration and you will then see an "Auto-Start" option available in the list on the left hand side. The default value is "Disabled", simply "Enable" this and click Apply - it will need to refresh the service then you are good to go.

    In addition, endpoint url's in your web.config will need to be updated e.g. http://localhost:8099/Service1.xamlx becomes http://localhost:8099/ServiceApplication/Service1.xamlx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, December 20, 2013 10:41 AM

All replies

  • Tuesday, December 3, 2013 10:17 AM
  • User2011366442 posted

    Hi Illeris,

    I've downloaded the Hotfix you have gave the link but I am presented with the message "The update is not applicable to your computer.", when I run the .msu file. I am running the correct O.S. version of the file (64 bit) so I assume this has already been applied at an earlier stage via another installation.

    Any ideas anyone?

    Many Thanks,

    Daniel

    Wednesday, December 4, 2013 5:03 AM
  • User2011366442 posted

    Bump ^

    Thursday, December 19, 2013 11:00 AM
  • User2011366442 posted

    After a lot of researching I have found out why it hadn't been working. The initial thread I was referring to was good for info but essentially too old and out of date. Please refer to this article from the MSDN Website:

    http://msdn.microsoft.com/en-us/library/ee677285.aspx

    Essentially, I had all my sites and services, in IIS, set up as a "Web Site". When you goto the WCF & WF Configuration set up, inside it does not contain an option saying "Auto-Start". What you have to actually do is setup the Service as an "Application" under a Web Site in IIS. Once you set it up, return to the WCF and WF Configuration and you will then see an "Auto-Start" option available in the list on the left hand side. The default value is "Disabled", simply "Enable" this and click Apply - it will need to refresh the service then you are good to go.

    In addition, endpoint url's in your web.config will need to be updated e.g. http://localhost:8099/Service1.xamlx becomes http://localhost:8099/ServiceApplication/Service1.xamlx

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, December 20, 2013 10:41 AM