locked
Mobile Web Application Error RRS feed

  • Question

  • User-1748863262 posted

    Hi Guys,

    I have created a mobileweb application for a University Dissertation and I am having problems launching the application on an actual mobile device. The application runs perfectly on an emulator. Basically I want to demonstrate the use of the application on an actual device ie a PDA but I get the following error.

    server error in '/' Application

    Runtime Error
    Description: An application error occurred on the server. The current custom
    error settings for this application prevent the details of the application
    error from being viewed remotely (for security reasons). It could, however,
    be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom
    error page by modifying the "defaultRedirect" attribute of the application's
    <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>

    I have changed the web.config file <customErrors mode="off"/> it was originally set to RemoteOnly mode, but I still get the same error. All am trying to do is type the IP address of my machine, followed by the path of the application ie http://ipaddress/mobilewebapplication1/login.aspx . I have created the application using MMIT in Visual Studio.NET using C# as the coding language. When I try putting address on an emulator ie http://localhost:8080/mobilewebapplication/login.aspx it works with no probs.

    Please help.

    Thanks, Nitin Patel

     


    Friday, April 22, 2005 8:58 AM

All replies

  • User664499748 posted

    Nitin, can you try browsing to the same address [ip and all] on emulator as you are doing on the actual device. Also in the above paths you have one as mobilewebapplication1 and the other as mobilewebapplication. Could it be that you are browsing to different apps on the emulator and the actual device.

    Thanks, Kashif

    Friday, April 22, 2005 12:41 PM