none
Page_Fault_in_nonpaged_area (nvads1.sys RRS feed

  • Question

  • I have a Surface 2, windows 8RT. Whenever I start to watch a video from hulu, in the middle of the video program my computer wants to restart, it states: PAGE_FAULT_IN_NONPAGED_AREA (nvads1.sys). Any suggestions on how to remedy this?

    Thanks,

    rducky

    Sunday, December 22, 2013 2:01 AM

All replies

  • Hello,

    First I would look for memory.dmp file in %WINDIR% folder and open it with latest WinDbg after configuring symbols in order to understand where the problem is.

    Alon

    Sunday, December 22, 2013 11:53 AM
  • The same thing happens to me when u watch Hulu as well. It appears to be happening during the transition from commercial to main video or main video to commercial.
    Monday, February 17, 2014 2:59 PM
  • Hi rducky

    As it was told by the other user you should open MEMORY.dmp dump file which is probably stored on C:\Windows directory with windbg and run !analyze -v command.Bear in mind that before using windbg you should have your public symbols installed.

    Usually drivers are not allowed to incur page fault while operating at DPC level 0x2.

    Thursday, February 20, 2014 8:01 AM
  • Hi rducky.

    I have the same error, have you found any solutions?

    Tuesday, March 4, 2014 3:28 PM
  • Can you upload windbg !analyze -v command output?
    Wednesday, March 5, 2014 7:11 AM
  • Happens for me too when using the Hulu app w/ surface2 Here is the info from mini dump

    Windows 8 Kernel Version 9600 MP (4 procs) Free ARM (NT) Thumb-2
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 9600.16452.armfre.winblue_gdr.131030-1505
    Machine Name:
    Kernel base = 0x81403000 PsLoadedModuleList = 0x815d8100
    Debug session time: Wed Mar  5 04:52:00.709 2014 (UTC - 5:00)
    System Uptime: 0 days 0:02:12.952
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************

    PAGE_FAULT_IN_NONPAGED_AREA (50)
    Invalid system memory was referenced.  This cannot be protected by try-except,
    it must be protected by a Probe.  Typically the address is just plain bad or it
    is pointing at freed memory.
    Arguments:
    Arg1: a30f1000, memory referenced.
    Arg2: 00000001, value 0 = read operation, 1 = write operation.
    Arg3: 908229db, If non-zero, the instruction address which referenced the bad memory
     address.
    Arg4: 00000000, (reserved)

    Debugging Details:
    ------------------


    Could not read faulting driver name
    TRIAGER: Could not open triage file : e:\dump_analysis\program\triage\modclass.ini, error 2

    WRITE_ADDRESS: GetPointerFromAddress: unable to read from 8163737c
    Unable to read MiSystemVaType memory at 815d75e0
     a30f1000

    FAULTING_IP:
    nvads1+69db
    908229da f8246b02 strh        r6,[r4],#2

    MM_INTERNAL_CODE:  0

    CUSTOMER_CRASH_COUNT:  1

    DEFAULT_BUCKET_ID:  CODE_CORRUPTION

    BUGCHECK_STR:  AV

    PROCESS_NAME:  System

    CURRENT_IRQL:  1

    LAST_CONTROL_TRANSFER:  from 81582e64 to 81582874

    STACK_TEXT: 
    9f2b57e8 81582e64 : 00000000 9f2b5868 87b3c480 81581b81 : nt!KeBugCheck2+0x130
    9f2b5ab0 8150ad2a : 00000000 00000000 9f2b5bc0 00000000 : nt!KeBugCheckEx+0x14
    9f2b5ac8 81442f0a : 00000000 ffff3424 ffff33ea ffff33ea : nt!MY_READ_REGISTER_UCHAR+0x700a
    9f2b5b38 81422b28 : 9f2b5b88 9f2b5b54 9f2b5b6c 9f2b5b48 : nt!MmAccessFault+0x5de
    9f2b5bc0 00000000 : 815f1530 00000001 a30f1000 81422400 : nt!KiCommonMemoryManagementAbort+0xcc


    STACK_COMMAND:  .bugcheck ; kb

    MODULE_NAME: memory_corruption

    IMAGE_NAME:  memory_corruption

    FOLLOWUP_NAME:  memory_corruption

    DEBUG_FLR_IMAGE_TIMESTAMP:  0

    MEMORY_CORRUPTOR:  LARGE

    FAILURE_BUCKET_ID:  ARM_MEMORY_CORRUPTION_LARGE

    BUCKET_ID:  ARM_MEMORY_CORRUPTION_LARGE

    Followup: memory_corruption


    :: Òlė Ðudė ::

    Wednesday, March 5, 2014 11:55 AM
  • Any progress with this? My friend just got a Surface 2, and is having exactly the same problem with Hulu. I have an RT which works fine...

    I imagine there'd be a lot more people complaining if this was a problem with all Surface 2s?
    Wednesday, March 12, 2014 11:07 AM
  • I am having this exact same issue.. I purchased my surface 2 when released and this has been happening multiple times. I did a repair then a full reset back in NOV 2013 this fixed the problem till about march. I have had to reset/ repair many times and this surface 2 is not the most stable. Now it does it all the time with Hulu I have all the updates and did the repair then full reset. Nothing seems to fix this. It always happens when between commercials or right after(just like stated above). Has anyone figured this out ? Was it fixed by a replacement? I really don't want to have to do a replacement unless that is my only option. 

    Thanks, 

    Chris

    Tuesday, April 29, 2014 8:44 PM
  • Unfortunately the link you supplied goes to such a generic location that it is all but useless because there's no solution there either. /slowclap.

    Garth H MCITP | BI 2008 MCTS | SQL 2005 & SharePoint 2010 http://bitinkering.spaces.live.com/

    Monday, July 28, 2014 6:11 AM
  • I have the same problem with my brand new Surface 2 on the Hulu Plus app. I'd love a step by step for someone who has only very basic knowledge of computers, (where to find common things, basic file types, etc.)
    Tuesday, September 16, 2014 9:42 PM
  • HI- I'm having the same problems on my surface 2, omg so frustrating to watch a show, I don't get why Hulu plus is making this happen :( HELP
    Tuesday, December 2, 2014 3:14 PM
  • Same exact error here. Almost every time I try to watch HULU. So frustrating. MS gets a minidump every time my S2 crashes so I know they know about it but it's an issue with the NVidia driver so all they can do is complain to NVidia.

    Dan T

    Tuesday, January 27, 2015 5:57 AM
  • I'm guessing that it's Hulu's fault because I don't get the issue anywhere else has anyone found a solution anywhere else?
    Friday, April 3, 2015 4:28 AM
  • I've never had this error, until today. I just watched a full episode on Hulu Plus. Then I tried to watch the next episode and got the error. Rebooted, attempted to watch again, same error. Then one more cycle of that. I'm pretty disheartened reading all of these posts w/ no resolotuion...c'mon MS + Hulu.
    Saturday, April 25, 2015 10:51 PM