none
disk has no volume attached on HCK testing RRS feed

  • Question

  • Hi,

    I have several HBA tests failing in HCK tests during the devicestatuscheck phase of the test:

         WDTF_SIMPLE_IO : Target:3PARdata VV SCSI Disk Device SCSI\DISK&VEN_3PARDATA&PROD_VV\7&3844D5C8&0&000000
    Error 7/16/2013 12:05:45.889 PM WDTF_SIMPLE_IO : Device not configured properly for basic testing: The Disk has no volume attached to it HRESULT=0x80040200

    So here is the disk/volume it is referring to:

    Here is that same volume in the device manager (which ties it back to the device name):

    The disk is hosted on a vhba or virtual HBA adapter. Clearly the test isn't seeing something it wants with the virtual disk. Can you give me some hints as to how it determines if there is a valid volume hosted on the disk?

    Thanks,

    Scott Moore

    Oracle

    Tuesday, July 16, 2013 9:07 PM

All replies

  • Note I even wrote some files to it and checked them to determine if there was a problem with the volume. Nothing was found, it is a valid disk as far as windows is concerned.

    Scott Moore

    Oracle

    Tuesday, July 16, 2013 9:32 PM
  • Hi Scott,

    Perhaps you need recreate the volume on the Disk device with the MBR(Master Boot Record).

    I always using the MBR when run the HCK testing for the Storage Array device.

    Thursday, July 18, 2013 2:42 AM
  • Thanks,

    I tried with both MBR and GPT boot sector types. Fails to find the volume on both. Also tried totally removing and reinstalling the volume and the drive several times.

    Scott

    Oracle

    Thursday, July 18, 2013 5:30 PM
  • The disk you're selecting for testing (the second picture you attached) is an MPIO'ed disk (where the volume is mounted on).  The disk the device fundamental test is looking for is the underlying disk device (no volume).  You should open a Microsoft CSS case and investigate further.

    This posting is provided AS IS with no warranties, and confers no rights.

    Tuesday, July 23, 2013 9:33 PM
  • Thanks, let me look at that.

    scott

    Tuesday, July 23, 2013 9:53 PM
  • Hi,

    Got any updates on this issue ? I am facing this problem in HLK Certification. 

    Thanks,

    Ruben

    Tuesday, August 23, 2016 10:41 PM