locked
Is it normal that warning on application re-install doesn't appear on every cab run? RRS feed

  • Question

  • When user starts cab file with update for the application he gets warned about currently installed version: "The previous version of <Your Application Name> will be removed before the new one is installed. Select OK to continue or Cancel to quit."
    Now selecting Cancel and closing installer works fine.
    But if user tries to start and cancel update several times warning stops popping up and installer just finishes as unsuccessful. If user waits for a minute or two warning starts popping up, but canceling update several times bring problem again.

    As I understand this is OS or wceload issue. Does anyone know if this behavior can be somehow omitted?
    Wednesday, February 10, 2010 8:05 AM

Answers

All replies

  • >>But if user tries to start and cancel update several times warning stops popping up and installer just finishes as unsuccessful.

    I think few users do this in real life. It may be an issue with wceload, it may also be an issue with your application, or it may just be supposed to be that way. You need to elaborate on how to reproduce the issue before we can tell.


    Please mark the post that helps you, and unmark that does not. This benefits our community.
    Friday, February 12, 2010 5:45 AM
  • I agree with you that in real life a few users might do this. Such a behavior was reported by tester in our company.
    I'm sure that this issue is not related to our product because I created simplest possible cab using Smart Device CAB Project and it behaves the same way.
    Friday, February 12, 2010 2:00 PM
  • >>But if user tries to start and cancel update several times warning stops popping up and installer just finishes as unsuccessful.
    >> it behaves the same way.

    This is what I call an ambiguous desciption. You need to make a *reproducible* description. Please read this guide:
    https://connect.microsoft.com/content/content.aspx?SiteID=425&ContentID=11404#Logs_and_Bugs_-_Advanced 

    If the issue is reproducible, please submit it to the Connect site where it can be addressed.



    Please mark the post that helps you, and unmark that does not. This benefits our community.
    • Marked as answer by warrentang Tuesday, February 16, 2010 6:59 AM
    Monday, February 15, 2010 5:20 AM