none
BTSHTTPReceive.dll 405 error RRS feed

  • Question

  • I have set up a virtual directory set up to point to the BizTalk “BTSHTTPReceive.dll”.  I am able to submit a unsigned and unencrypted AS2 file to the URL without any issues using the Sender application in the BizTalk Samples.  When my trading partner tries to send a file (which is signed and encrypted) they are getting a 405 method not Allowed error.  I am seeing no errors in BizTalk or the windows event log.  The IIS logs are showing the 405 error.  It looks like the post if failing in IIS so I can’t determine of if there is anything in my BizTalk setup that is causing this error.

     

    My trading partner assured me they requesting the MDN Asynchronously. 

     

    Would anything in my BizTalk configuration for the party or the receive location cause a 405 error that is not logged in BizTalk or in the windows event logs?

     

    Thanks in advance.

    Wednesday, January 6, 2010 8:12 PM

Answers

  • Thanks for the replys.  The fix was to have the trading partner add "BTSHTTPReceive.dll" to the URL they were using.  I don't understand it because I was able to post without any issues without the dll name in the URL.

    Tom
    • Marked as answer by ParahT Friday, January 8, 2010 10:50 PM
    Friday, January 8, 2010 10:50 PM

All replies

  • I think a 405 might occur if your company firewall does not allow connections from outside to your endpoint address where you have BTSHTTPReceive.dll.

    Also, you may need to create a Windows Firewall exception if Windows Firewall is running on your server.

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Thursday, January 7, 2010 11:07 PM
    Moderator
  • Hello ParahT,

    Double check your IIS settings on the BTSHTTPReceive.dll and make sure you have the "POST" HTTP method enabled as the only HTTP method allowed.
    What you can also do is put a tool like TCPTrace.exe (see http://www.tcptrace.org/download.html) in between to check what method they are actually using. BTSHTTPReceive.dll only allows the POST method and will generate an error if you try to do this with GET!

    More details on how to configure IIS can be found here.

    Best regards,
    Pieter
    Friday, January 8, 2010 8:18 AM
  • Thanks for the replys.  The fix was to have the trading partner add "BTSHTTPReceive.dll" to the URL they were using.  I don't understand it because I was able to post without any issues without the dll name in the URL.

    Tom
    • Marked as answer by ParahT Friday, January 8, 2010 10:50 PM
    Friday, January 8, 2010 10:50 PM