none
Event Errors When Trying to Process Inbound AS2 Message RRS feed

  • General discussion

  • I am currently receiving the following errors in event log when trying to process inbound AS2 transmissions for a new BizTalk Server 2009 installation:

    The BizTalk HTTP receive adapter failed to initialize itself. Possible reasons:

    1) Receive location URL is not created/configured correctly.

    2) Receive location is not enabled.

    3) HTTP receive adapter is not running under a user that has access to management and message databases.

    4) Isolated host instance is not created for HTTP Receive adapter.

    ***************************************************************

    The Messaging Engine failed to register the adapter for "HTTP" for the receive location "/hitachi/btshttpreceive.dll". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases.

    ***************************************************************

    I believe I have correctly set-up everything and have reviewed many website posts regarding these errors to no avail.

    Any thoughts?

    Many thanks,

    Frosty


    Tom Frost Frost Data Systems 508-494-8633 tom@frostdatasystems.com
    Friday, May 20, 2011 2:15 PM

All replies

  • Hi,

    Confirm that the Identiy associated with your AppPool in IIS is in the BizTalk Administrators group.

    Thanks,

    William

    Friday, May 20, 2011 4:01 PM
  • What happens when you browse to: "/hitachi/btshttpreceive.dll"?  It should try to open the DLL unless you've turned off GET in IIS.  Most likely this is a permissions issue.  Did you create a BizTalk receive location with the uri: /hitachi/btshttpreceive.dll?  Did you also set up the handler for *.dll?

     

    If I recall that user also needs log on as service rights. 

     

    Kind Regards.

    -Dan


    If this answers your question, please Mark as Answer
    Sunday, May 22, 2011 12:59 PM