locked
Remote Debugging with the Debugger Engine stuff RRS feed

  • Question

  • Hello there.

    I am using IDebugClient and other debug engine interfaces for my small debugger, and all goes well. The problem starts when i try to use one of the remote functions, StartServer() , StartProcessServer() and even DebugConnect(). All fail with error 0x8007053d "The server is currently disabled. "

    What does that mean and how am I supposed to fix it? dbgsrv.exe works without problems.

    Best Regards.



    Michael
    Thursday, January 28, 2010 8:18 PM

Answers

  • Make sure the dbgeng.dll you are using is the one from the debugger install and not the one that ships with Windows. That solved the problem for me.
    • Marked as answer by WindowsNT Monday, December 5, 2011 7:05 PM
    Saturday, April 17, 2010 6:30 PM

All replies

  • Hi Michael,

    Please try this support article:

    http://support.microsoft.com/kb/891330

    Thank you,

    Kelly Evans

    Thursday, January 28, 2010 10:29 PM
  • What has application server 2000 got to do with the debugging interfaces ? What has Windows Server 2003 got to do with it ? The hotfix doesn't even install If I try it.

    There is nothing to fix, since dbgsrv.exe works. There must be some call I am missing.



    Michael
    Friday, January 29, 2010 5:48 AM
  • Make sure the dbgeng.dll you are using is the one from the debugger install and not the one that ships with Windows. That solved the problem for me.
    • Marked as answer by WindowsNT Monday, December 5, 2011 7:05 PM
    Saturday, April 17, 2010 6:30 PM