none
WCF Error "Could not find a base address that matches scheme https for the endpoint with binding BasicHttpBinding. Registered base address schemes are [http]. "

    Question


  • Hi,

    I have created one WCf
    service for  to test username
    Authentication  with security mode="TransportWithMessageCredential"

    I am getting the following error while starting my
    Service.

    "Could not
    find a base address that matches scheme https for the endpoint with binding
    BasicHttpBinding. Registered base address schemes are [http].

    Please check my web.config file for the WCF
    service.

    -----------------------------------------------------------------------------------------

    <configuration>

    <system.web>

    <compilation debug="true" targetFramework="4.0" />

    </system.web>

    <system.serviceModel>

    <services>

    <service behaviorConfiguration="ServiceBehavior" name="myWcfSecureService.Service1">     
    <
    host>   
    <
    baseAddresses>

                <add baseAddress="http://localhost:3705/Service1"/>                   
    </
    baseAddresses>    
    </
    host>   
    <
    endpoint  binding="basicHttpBinding" bindingConfiguration="test" contract="myWcfSecureService.IService1" >      
    <
    identity>        
    <
    dns value="localhost"/>      
    </
    identity>   
    </
    endpoint>  
    <
    endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange"/>    
    </
    service>  
    </
    services>  
    <
    bindings>   
    <
    basicHttpBinding>            
    <
    binding name="test">                
    <
    security mode="TransportWithMessageCredential">

                <message clientCredentialType="UserName"/>          
    </
    security>      
    </
    binding>    
    </
    basicHttpBinding>  
    </
    bindings>  
    <
    behaviors>    
    <
    serviceBehaviors>     
    <
    behavior name="ServiceBehavior">       
    <
    serviceMetadata  httpsGetEnabled="true"/>      
    <
    serviceDebug includeExceptionDetailInFaults="true"/>   
    <
    serviceCredentials>       
    <
    userNameAuthentication userNamePasswordValidationMode="Custom" customUserNamePasswordValidatorType="myWcfSecureService.MyValidator,
    myWcfSecureService
    "/>
          
    </serviceCredentials>      
    </
    behavior>  
    </
    serviceBehaviors>   
    </
    behaviors>
    </
    system.serviceModel>

    </configuration>



    Roshil K

    Friday, February 24, 2012 11:17 AM

Answers

  • Refer to this thread.

    http://social.msdn.microsoft.com/Forums/en-US/wcf/thread/9c386cdb-90fb-426e-b8f2-f06811390e56


    Welcome to MSDN Forums. Feel free to ask your questions and Please Note to Vote helpful topics and Mark answering posts. Sudhakar

    • Marked as answer by Roshil Saturday, February 25, 2012 7:15 AM
    Friday, February 24, 2012 1:04 PM