VS2008 Server Explorer "Unable to find the requested .Net Framework Data Provider. It may not be installed." RRS feed

  • Question

  • Hello,

    A couple months ago I was connecting to an IBM DB2 AS400 database through Server Explorer in VS2008 using OLE DB. I was able to do this without any problems and query the database as needed. However, now I need to go back to the project and upon trying to connect to and open the database in Server Explorer I get the error: "Unable to find the requested .Net Framework Data Provider.  It may not be installed".

    I am able to connect to the database through code with no problem. I am able to connect and query the database using Server Explorer in VS2010 with no problems. I have tried looking up the problem on forums, however none of the answers I have found apply to me. There were answers about an extra closing tag </DbProviderFactories> and <DbProviderFactories/> in machine.config, this is not present in my machine.config file

            <DbProviderFactories><add name="Microsoft SQL Server Compact Data Provider" invariant="System.Data.SqlServerCe.3.5" description=".NET Framework Data Provider for Microsoft SQL Server Compact" type="System.Data.SqlServerCe.SqlCeProviderFactory, System.Data.SqlServerCe, Version=, Culture=neutral, PublicKeyToken=89845dcd8080cc91"/></DbProviderFactories>


    Others have said it might be a .NET issue, however since I can access the database through code and through VS2010 I feel that this is unlikely...I've spent a few hours trying to solve this and nothing seems to be working, so any help is appreciated!



    • Moved by Vicky SongMicrosoft employee Monday, July 16, 2012 2:29 AM (From:Visual Studio Database Development Tools (Formerly "Database Edition Forum"))
    Friday, July 13, 2012 12:26 PM

All replies

  • Hello Megan,

    I am moving your issue to the ADO.NET Managed Providers forum so that  you can get better support there.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Monday, July 16, 2012 2:29 AM
  • Did you check the app.config or web config of your project? If you create a new project in VS 2008 do you still have the problem?

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, July 16, 2012 11:58 AM
  • Yes, the app.config  is correct, I'm using the same database information that's there to connect in VS2010. I tried creating a new project and still had the same error.

    I've been using VS2010 as a work around since Friday but I'd still like to figure out why it won't work in VS2008.

    • Edited by megab16 Monday, July 16, 2012 3:15 PM
    Monday, July 16, 2012 3:14 PM
  • OK, well there is a machine.config for each version of the .NET Framework. Did you check the version that you are using in your project for VS 2008?

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, July 16, 2012 3:45 PM
  • Yes, I checked all of them in Framework and Framework64 folders and it's definitely not the error most people were reporting (the extra closing tag). If there is another error there I am not able to recognize it.
    Monday, July 16, 2012 4:10 PM