none
I am getting duplicate results in bing map search service. Does anyone know any workaround. see reproduced steps in details RRS feed

Answers

  • I'm getting the same behavior and I reported it as a bug to the technical support.
    I hope it will be fixed asap since this behavior is not what we want in our applications.

    The only precaution that we can make is to filter on the entitytype returned in the response in order to only get PopulatedPlaces, it's not fixing the issue but it's avoiding the fact that we get 2 results in the user interface, see EntityTypes:

    http://msdn.microsoft.com/en-us/library/ff728811.aspx

    Microsoft needs to update the service response in order to minimize the size of the response and only include PopulatedPlace by default and let developer specify other entity types if we want to do so.


    MVP - Bing Maps - My blog (FR): http://blogs.developpeur.org/nicoboo/ Twitter: http://twitter.com/nicolasboonaert/

    Monday, March 26, 2012 10:32 AM
    Moderator

All replies

  • I'm getting the same behavior and I reported it as a bug to the technical support.
    I hope it will be fixed asap since this behavior is not what we want in our applications.

    The only precaution that we can make is to filter on the entitytype returned in the response in order to only get PopulatedPlaces, it's not fixing the issue but it's avoiding the fact that we get 2 results in the user interface, see EntityTypes:

    http://msdn.microsoft.com/en-us/library/ff728811.aspx

    Microsoft needs to update the service response in order to minimize the size of the response and only include PopulatedPlace by default and let developer specify other entity types if we want to do so.


    MVP - Bing Maps - My blog (FR): http://blogs.developpeur.org/nicoboo/ Twitter: http://twitter.com/nicolasboonaert/

    Monday, March 26, 2012 10:32 AM
    Moderator
  • I've scanned through the xml response and the entitytype values for all the location elements are set to PopulatedPlace already. For instance, searching for Milton Keynes brings back 2 location results - Milton Keynes, Milton Keynes & Milton Keynes - each specifying entitytype as PopulatedPlace. So basically filtering on the entitytype will make no difference.

    Any other suggestion or a workaround?

    Thanks

    Tuesday, April 10, 2012 1:23 PM