none
CreateInstance failed for package [Microsoft Visual Studio Tools for Applications 2012 Shell Integration Package]

    Question

  • I am migrating from a Windows 7 Pro computer to a Windows 10 Pro computer at work.  I had first tried LapLink's PC Mover which caused a bit of a disaster for my SQL server installation, so I rolled back and installed Visual Studio 2012 from the distribution.  When I started VS 2012 up, I was getting some errors that were easy to handle going back and forth to the old computer, but this one won't go away and shows up when I load the first project after starting DevEnv.exe.

    The error in ActivityLog.xml is: CreateInstance failed for package [Microsoft Visual Studio Tools for Applications 2012 Shell Integration Package]

    I have tried repairing and even reinstalling to no avail.

    Are there any ideas out there on how to eliminate this error?

    Thanks,

    mike

    Thursday, October 20, 2016 6:27 PM

All replies

  • Hi mike,

    Thank you for posting in MSDN forum.

    >>[Microsoft Visual Studio Tools for Applications 2012 Shell Integration Package]

    The error information already shows that Shell (Integrated) failed to load.

    Have you installed Microsoft Visual Studio 2012 Shell (Integrated) Redistributable Package ?

    If not , please install it from following link:

    https://www.microsoft.com/en-us/download/details.aspx?id=30663

    Then restart VS again check if the error exists.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, October 21, 2016 9:30 AM
    Moderator
  • Thank you for answering.  I tried that again this morning and the error persists.  I don't know if it will affect anything, but I would still like to resolve it.  Is there anything else that I could try?

    mike

    Friday, October 21, 2016 1:42 PM
  • Hi mverbeke,

    I have met similar cases before: some community members have trouble about VS after upgrading to Win 10.

    Please see this similar issue and the solutions from TimVdG, enden, Björn Blissing and other community members looks reasonable.

    TimVdG: repair the 2015 Visual C++ redistributables and restart the visual studio installer.
     
    Enden: 9 solutions and see the detail information from the above website

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, October 24, 2016 8:43 AM
    Moderator