locked
Club site dependent on SQL Server? RRS feed

  • Question

  • User-1623236949 posted

    I have removed all the references to the SqlExpress in the web.config but as soon as take it off line the application breaks, ie login errors out with sql error.

    Thank you,

    EJM

    Monday, October 10, 2011 12:21 PM

Answers

  • User-1623236949 posted

    I forgot I had this posting. I figured out what was the issue. Missing this line in my web.confing.

    <remove name="LocalSqlServer"/>
    <add name="LocalSqlServer" connectionString="Data Source=,server name.;Initial Catalog=Club;User ID=<userid>;Password=<password>;" providerName="System.Data.SqlClient"/>
    	
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, December 29, 2011 2:26 PM

All replies

  • User1992938117 posted

    I have removed all the references to the SqlExpress in the web.config but as soon as take it off line the application breaks, ie login errors out with sql error.

    May be they r using Sqldatasource in designer code?

    Monday, October 10, 2011 12:24 PM
  • User-1623236949 posted

    May be they r using Sqldatasource in designer code?

    Thaks for your reply. I have looked at all the datasource declarations in my project and all look like this:

    <asp:SqlDataSource ID="SqlDataSource1" runat="server" ConnectionString="<%$ ConnectionStrings:ClubSiteDB %>".... where the connection string is pointing to the webconfig's property, which is like this:
    <add name="ClubSiteDB" connectionString="Data Source=serverName;Initial Catalog=dataBaseName;User ID=****;Password=******;" providerName="System.Data.SqlClient"/>
     
    Thanks.
    EJM
    Monday, October 10, 2011 12:45 PM
  • User-1623236949 posted

    No one has any other suggestions?

    Thursday, October 13, 2011 11:14 AM
  • User1275632693 posted

    From what I remember you would have to change your Connection string so you would no longer point to SQL Express but to a full blown SQL server.

    Should not be too difficult to tweak.

     

    Monday, October 24, 2011 12:07 PM
  • User-1623236949 posted

    I forgot I had this posting. I figured out what was the issue. Missing this line in my web.confing.

    <remove name="LocalSqlServer"/>
    <add name="LocalSqlServer" connectionString="Data Source=,server name.;Initial Catalog=Club;User ID=<userid>;Password=<password>;" providerName="System.Data.SqlClient"/>
    	
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, December 29, 2011 2:26 PM