none
Enabling Microsoft endpoint security through service definition settings RRS feed

  • Question

  • Hi,

    We followed steps provided in https://azure.microsoft.com/en-us/blog/microsoft-endpoint-protection-for-windows-azure-customer-technology-preview-now-available-for-free-download/ for enabling endpoint protection in Azure web role VMs automatically during deployment.

    But getting "Azure Endpoint Protection Installer stopped working" error message on trying to run web role locally using azure emulator and same is the issue on trying to deploy to azure as well

    Do we need to carry any other settings apart from steps mentioned in above link to make things working. The azure sdk version is 2.7

    Thanks you in advance!


    • Edited by MSUser2015 Wednesday, November 4, 2015 12:57 AM
    Wednesday, November 4, 2015 12:56 AM

All replies

  • Hi MSUser2015,

    The article you are referring to is outdated, and I am not sure if it applies to the latest version.
    I would suggest you refer to the below article on Microsoft Antimalware for Cloud Services and Virtual Machines.
    https://azure.microsoft.com/en-us/blog/microsoft-antimalware-for-azure-cloud-services-and-virtual-machines/

    Let us know if this helps.

    Regards,
    Nithin Rathnakar
    Wednesday, November 4, 2015 4:30 PM
  • Hi Nithin,

    Thanks for your response. I gone through the site and it talks about enabling antimalware via powershell cmdlets.Is there any way to enable this via config settings in servicedefinition file like including below import as mentioned in older post,

    <Import moduleName="Antimalware"/>

    or this option is not no more available and things needs to be done via powershell cmdlets only

    Wednesday, November 4, 2015 7:52 PM