locked
Help installing FASTCGI Handler - Server 2003/PHP 4.4.6 currently using isapi/PHPBB RRS feed

  • Question

  • User-1307717961 posted

    Well attempted to install the FASTCGI and it didn't work at all - so figure doing something incorrectly.

     Used the instructions at this link

     http://www.iis.net/default.aspx?tabid=2&subtabid=25&i=1345&p=2

     Our current setup

    Server 2003

    PHP 4.4.6 using isapi dll

    IIS6

    PHPBB

    Could someone guide us through a proper installation with this config as hoping this will be a faster and more stable setup than what we already have

     

    Thanks

     

     

    Tuesday, April 3, 2007 4:44 PM

All replies

  • User-1653247517 posted
    What's the error you are getting? Can you tell scriptmaps set on your machine? You can use the following command.

    %systemdrive%\inetpub\adminscripts\adsutil.vbs get /w3svc/scriptmaps

    - Kanwal
    Wednesday, April 4, 2007 2:59 AM
  • User-1307717961 posted

    Ok, this is what we did.

    1st, our setup again is

    Server 2003

    IIS6

    PHP 4.4.6 running in ISAPI mode

    PHPBB

    1st we went to the website extensions in IIS and deleted the PHP allowed then we went to the website in IIS and deleted the .php.  Both of these were pointing to the ISAPI dll file in the C:\PHP\SAPI directory

    Then we ran the installation and script mapping per the exact instructions in the link above.  Everything installed properly.  We checked by going into IIS and in Extensions there was a new one for FastCGI pointing to the DLL file in the system32/intserv directory and then checking the website in IIS, the new .php was there again pointing to the same DLL

    We tried to view our test.php page and it would not work whatsoever.  Then ran the uninstall and that went fine - reinstalled the isapi php in IIS and everything back to the original config working fine

    Wednesday, April 4, 2007 1:10 PM
  • User-679828332 posted

    Hi JLAF,

    Did you get a response from the web server? If so, please could you share it.

    Note that browser caching sometimes tricks me and I find Ctrl-F5 gives more expected results than F5.

    Cheerz,

    Rick.

    Wednesday, April 4, 2007 9:59 PM
  • User-1307717961 posted

    Received a 404 error on the test.php file

    Tried changing the name and then browsing to that file - same result

     

    Switched back to ISAPI, and it came up fine

    Thursday, April 5, 2007 8:51 AM
  • User-679828332 posted

    Hi JLAF,

    These are best debugged with procmon from www.sysinternals.com. Could you see:

    - what file w3wp.exe is trying to access

    - what the return is (access denied or not found)

    Thanks,

    Rick.

     

    Thursday, April 5, 2007 7:18 PM