locked
suspending event

    Question

  • Hello guys.

    Quick question: when does the suspending event (fired by WebUIApplication object) gets raised? I've built a really simple app and I'm trying to use an extended splash screen. I've noticed that the activated event does get fired, but I'm not getting anything form the suspending event. I've tried using task manager and the truth is that I cannot see the state of my app being transitioned to suspended like it happens with the default win 8 metro apps that are preinstalled in the OS. I expected to see it transition to the suspended state after loosing focus and being in the background for a few seconds. am i wrong?

    Am  I missing something?

    thanks.


    Luis Abreu
    Thursday, January 12, 2012 2:41 PM

All replies

  • Hey Luis,

    I have seen this when debugging an app in VS.  VS however gives you an option to trigger the suspend.  When debugging simply choose 'Trigger Suspend' from the 'Debug' menu.

    -Jeff


    Jeff Sanders (MSFT)
    Thursday, January 12, 2012 3:39 PM
    Moderator
  • Hello Jeff.

    I've already tried running the demo app from the main tile menu (by clicking over it) and I still can't get it suspended after transitioning to another win 8 metro app...any clues?


    Luis Abreu
    Friday, January 13, 2012 11:21 AM
  • Hi Luis,

    I have not seen this before.  What if you create a blank WWA and run it by launching it from the tile?  Is there something unique about your app?  I definitely cannot reproduce your situation here.

    -Jeff


    Jeff Sanders (MSFT)
    Friday, January 13, 2012 1:56 PM
    Moderator
  • Hello again.

    I've created a new blank project and I've been using the same project for testing purposes. btw, I've dowloaded the sample projects and I've built and ran the advanced tile sample project. I've noticed that it won't also get into the suspended state when it looses focus. probably there's something wrong with my machine...


    Luis Abreu
    Friday, January 13, 2012 3:09 PM
  • Hello again.

    I've created a new blank project and I've been using the same project for testing purposes. btw, I've dowloaded the sample projects and I've built and ran the advanced tile sample project. I've noticed that it won't also get into the suspended state when it looses focus. probably there's something wrong with my machine...


    Luis Abreu

    Hi, Luis, did you get your problem solved when you changed a new machine? I got the same problem with you that the suspending event can't be fired when switch to other app or desktop...
    Monday, February 6, 2012 8:20 AM
  • Well, I'm not sure on what happened...I've tried it in another machine and it worked ok...

    Luis Abreu

    Thursday, February 9, 2012 11:55 AM