locked
Is there a version of WinCache Extension for PHP that is compatible with Windows Server 2012 and PHP 5.2.14? RRS feed

  • Question

  • User302851450 posted

    I have tried to install wincache-1.1.0-5.2-nts-vc6-x86.exe on a Windows 2012 server with PHP 5.2.14 and the Zend Scripting Language Engine:
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
        with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
        with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies

    I keep getting errors similar to this:

    Faulting application name: php-cgi.exe, version: 5.2.14.14, time stamp: 0x4c4731f0
    Faulting module name: php-cgi.exe, version: 5.2.14.14, time stamp: 0x4c4731f0
    Exception code: 0xc0000005
    Fault offset: 0x0000191a
    Faulting process id: 0x1428
    Faulting application start time: 0x01d0997f68f7b4b8
    Faulting application path: C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP5\php-cgi.exe
    Faulting module path: C:\Program Files (x86)\Parallels\Plesk\Additional\PleskPHP5\php-cgi.exe
    Report Id: a6a44096-0572-11e5-940f-d4ae52ce89b9
    Faulting package full name:
    Faulting package-relative application ID:

    Before I spend more time troubleshooting, is there a version of WinCache that is compatible with both Windows Server 2012 and PHP 5.2.14 ? If so, which one?

    Can it be the Zend engine that is not compatible with WinCache?

    Thank you!

    Lena

    Thursday, May 28, 2015 5:54 PM

All replies

  • User409000176 posted

    PHP 5.2 has been deprecated and is no longer supported.  I don't know the last version of WinCache that was built for PHP 5.2; it was before I started working on WinCache.

    If I may ask, why are you using PHP 5.2?

    Thx!

        --E.

    Friday, May 29, 2015 6:20 PM
  • User302851450 posted

    Thank you for your response!

    I am maintaining an e-commerce website that was written for PHP 5.2 and (we have tried) won't run at all on 5.3 or higher. Upgrading requires changes throughout the codebase, so while that work is ongoing, I need to keep the old site running as efficiently as possible.

    Thank you!

    Lena

    Monday, June 1, 2015 8:44 AM
  • User409000176 posted

    LenaNi2000--

    Wow, my heart goes out to you.

    We only build WinCache for PHP 5.4, 5.5 & 5.6.

    What you *could* do is build your own copy of PHP 5.2 from the sources out on https://pecl.php.net/package/WinCache .  Of course, this involves setting up the vc6 compiler and gathering all of the dependent libraries, as well as downloading the PHP 5.2 sources.  I've never done this, so you'd be pretty much on your own...

    Thx!

        --E.

    Monday, June 1, 2015 2:53 PM