locked
How change asp.net version in iis 7.5 RRS feed

  • Question

  • User-1640206645 posted

    Hi,

    i just install windows 7, and i got iis 7.5. then i install all of my application software, like sql server 2005 and visual studio 2005. in the beginning all just fine, it seems that the default asp.net configuration is version 2. then i install the .net framework 1.1, because i have an application runs on the fw. now the problem come, everytime i open my project (web app) in  visual studio, there's always warning that my application(web app) configuration is based on version 1.1, then i was asking to change to version 2, i always answer yes, but every time i close and open the application, the same question appear.

    i already try to configure in iis. i already set the default website application pool is DefaultAppPool, which was in .net 2 and integrated pipeline. and i also set my application to whether DefaultAppPool or ASP.NET 2.0. but why everytime i open my web application project, there's always a warning, that my application configuration is using the .net 1.1. is there any other way, how to change this problem. please help. thanks

    yugi

    Sunday, November 15, 2009 8:28 PM

Answers

  • User-619846739 posted

    In your VS project, do you have it set for debugging using the built-in web server (Cassini) or IIS7?  If it's the default, which is the built in web server, then the issue isn't with IIS but it's with the Visual Studio settings.

    If you look at the properties of the project after you've selected "yes" to upgrade the framework version, what's the target framework version?  Something in the project must make Visual Studio think that it's using v1.1.  I bet you can even answer 'no' to that prompt and it will still work well for you, although I'm sure you would like to get rid of the prompt.

    This question may be better on forums.asp.net (your username/password will work there too).  This is probably from a setting in Visual Studio and not from IIS.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 9:42 AM

All replies

  • User-619846739 posted

    It sounds like you checked the right things.  Here's what I suggest to do or double check:

    • .NET 1.1 may have agressively taken over part of IIS.  Try running aspnet_regiis /i from the command prompt for the v2.0 folder.  (c:\windows\microsoft.net\framework\v2.0.50727).  That will register asp.net 2.0 but won't mess up 1.1.  This is the most likely fix.
    • confirm which IIS site is handling your website, then confirm which app pool it's running under.  It may not be using the DefaultAppPool.  Then confirm that the framework version is correct.
    • Check your project properties in Visual Studio to see if they changed properly.  Check your web.config to see if any framework settings are set there.
    Sunday, November 15, 2009 9:19 PM
  • User-1640206645 posted

    Hi scot, thanks for the response, but i'm afraid it still not working. i already try all of your suggestion, but it still not working. is there any other way? thanks

     yugi

    Monday, November 16, 2009 1:25 AM
  • User-619846739 posted

    In your VS project, do you have it set for debugging using the built-in web server (Cassini) or IIS7?  If it's the default, which is the built in web server, then the issue isn't with IIS but it's with the Visual Studio settings.

    If you look at the properties of the project after you've selected "yes" to upgrade the framework version, what's the target framework version?  Something in the project must make Visual Studio think that it's using v1.1.  I bet you can even answer 'no' to that prompt and it will still work well for you, although I'm sure you would like to get rid of the prompt.

    This question may be better on forums.asp.net (your username/password will work there too).  This is probably from a setting in Visual Studio and not from IIS.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, November 16, 2009 9:42 AM