none
Mapping repeating node RRS feed

  • Question

  • The TS837_2400_Loop  repeats multiple times in the XML feed and needs to repeat in the LXLoop1 edi as well.   How can I get this to pickup all the repeating values.  Right no wit just gives me the first value in the edi and does not pick up the rest.

    <TS837_2400_Loop>

         <LX_ServiceLineNumber>

             <LX01_AssignedNumber>1</LX01_AssignedNumber>

          </LX_ServiceLineNumber>

    </TS837_2400_Loop>

    <TS837_2400_Loop>

         <LX_ServiceLineNumber>

             <LX01_AssignedNumber>2</LX01_AssignedNumber>

          </LX_ServiceLineNumber>

    </TS837_2400_Loop>

    <TS837_2400_Loop>

         <LX_ServiceLineNumber>

             <LX01_AssignedNumber>3</LX01_AssignedNumber>

          </LX_ServiceLineNumber>

    </TS837_2400_Loop>

    Wednesday, September 16, 2015 5:20 PM

Answers

  • Ok, I found the Answer.

    The inbound schema for the TS837_2400_Loop was not set to UNBOUNDED.

    • Marked as answer by SoCal-Ed Wednesday, September 16, 2015 10:05 PM
    Wednesday, September 16, 2015 10:05 PM

All replies

  • Your LXLoop1 must be set to unbounded. The default is 1.

    Wednesday, September 16, 2015 6:00 PM
    Moderator
  • Thanks, but I checked that and show the loop as unbounded.  Any other ideas?

    Wednesday, September 16, 2015 6:08 PM
  • Ok, I found the Answer.

    The inbound schema for the TS837_2400_Loop was not set to UNBOUNDED.

    • Marked as answer by SoCal-Ed Wednesday, September 16, 2015 10:05 PM
    Wednesday, September 16, 2015 10:05 PM