none
UserTipControl is not defined when launching V8 map directions from Android Chrome RRS feed

  • Question

  • Currently the V8 map web control is getting a UserTipControl is not defined error when using Chrome desktop with emulated Nexus 5x and the latest Chrome 64.0.3282.137 on Android 7.1.1

    The error occurs here on an injected Javascript when in the webcontrol API

    6658eeb0.js?bu=rms+answers+MapsSDKRelease+AnonymousBegin*InternalControls.en*InternalControlsPluginStart*MobileTaskBarTemplate*TaskBarViewModel*MobileTaskBarViewModel*TaskBar*TaskBarItem*PrintDialog*PrintLogHelper*PrintDialogViewModel*PrintManager*SharingDialog*SharingDialogViewModel*SharePanelTemplate*SharePanel*SlideOutMenuTemplate*SlideOutMenuViewModel*SlideOutMenu*CommutabilityControl*CommutabilityControlTemplate*InternalControlsPluginEnd*AnonymousEnd:formatted:3085

    r.UserTipControl = UserTipControl

    I can handle the error for now, but ultimately I'd like to know if I'm missing something, reference or otherwise, which would trigger this.

    Thanks!

    Monday, February 26, 2018 8:02 PM

Answers

All replies

  • I'm not able to reproduce this. I'm using the Nexus 5x emulator in Chrome versions 63 and 64.

    [Blog] [twitter] [LinkedIn]

    Monday, February 26, 2018 11:28 PM
  • Can you please try my JS fiddle here:

    https://jsfiddle.net/p61fj83z/

    You'll need to insert your own map key.

    Use Chrome and change emulation to Nexus 5x on emulation mode, run the script. You should see an error in the debugger.





    • Edited by jwang-hitachi Tuesday, February 27, 2018 1:30 AM minor tweak to jsfiddle
    Tuesday, February 27, 2018 1:24 AM
  • Tried this, it worked fine, no errors. Tried it several times with different settings an emulators just in case. 

    [Blog] [twitter] [LinkedIn]

    Tuesday, February 27, 2018 11:30 PM
  • Did you check the F12 developer console for the error?

    Here is how I would run it:

    Load the JSFiddle

    Hit F12, reveal the dev console

    JSFiddle - Run - works fine

    Change web inspector to toggle device toolbar, choose an Android Device, Galaxy S5, Nexus 5x etc.

    JSFiddle - Run - See the error in console.

    • Edited by jwang-hitachi Wednesday, February 28, 2018 7:21 PM added repro steps
    Wednesday, February 28, 2018 7:18 PM