none
Start Visual Studio minimized and without a splash screen

Answers

All replies

  • Hi Frank

    Can you try this?

    To remove the splash screen you must edit the properties of the shortcuts that you use to launch Visual Studio. Right-click the shortcut and choose "Properties" from the menu that appears. You should see a dialog box similar to that pictured below. Add the "/nosplash" switch to the target of the shortcut to disable it.

    http://www.blackwasp.co.uk/VSNoSplash.aspx

    Thanks

    Ram

    Friday, October 07, 2016 3:00 PM
  • That took care of the splash screen, but the Visual Studio window is not minimized.

    In the shortcut properties, I have selected Run Minimized, but this does not seem to work.

    Regards


    Frank

    Friday, October 07, 2016 3:53 PM
  • Hi Frank,

    I have the same behavior with yours. I can start the visual studio without the splash screen, but the viausl studio can't be minimized even I have select the Run Minimized.

    This option seems only be apply to windows application. If I set this for my windows form application, the windows form application can be minimized.

    Naturally, you could also select “minimized” to have the program start that way instead.

    As I said, there are a couple of caveats:

    • Some programs override this. By that I mean that when they start, they explicitly decide whether they want to be minimized, maximized or “normal”. The upshot is that they effectively ignore this setting. You’ll need to check with that particular program if there’s a way to alter this behavior.
    • This works on programs, and shortcuts to program, but not documents or other files. For example if you have a shortcut to a Microsoft Word document on your desktop you will not see the Run option. However if you have a shortcut to Microsoft Word itself, you will.
    • Shortcuts in your start menu count. By that I mean, if in your start menu you have a shortcut to an application, you can right click on that menu item and click on properties, just as if it were a shortcut on your desktop of somewhere else

    Please refer to this:

    https://askleo.com/how_do_i_get_a_windows_program_to_always_open_maximized/

    Best Regards,

    Lake Xiao

    Saturday, October 08, 2016 3:42 AM
    Moderator
  • Hi Frank,

    If you are really interested, you can launch VS using automation:

    http://www.mztools.com/articles/2005/MZ2005005.aspx

    The DTE object has a DTE.MainWindow property, and the Window object has a WindowState property that can be set to WindowState.vsWindowStateMinimize


    My portal and blog about VSX: http://www.visualstudioextensibility.com
    Twitter: https://twitter.com/VSExtensibility
    MZ-Tools productivity extension for Visual Studio: http://www.mztools.com

    Sunday, October 09, 2016 6:46 AM
  • Hey Frank

    Have you tried changing the Shortcut option shown below?

    Thanks

    Ram

    Wednesday, October 12, 2016 4:54 PM
  • Hi Frank,

    >>In the shortcut properties, I have selected Run Minimized, but this does not seem to work.

    For this, I have report this to the Microsoft Connect:

    https://connect.microsoft.com/VisualStudio/feedback/details/3106958

    You can vote it and add your comments.

    Best Regards,

    Lake Xiao

    Sunday, October 16, 2016 2:09 AM
    Moderator
  • Edit the shortcut

    "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\devenv.exe" /nosplash

    hope this will  work


    RaSa

    • Proposed as answer by Syed_Rabbani Tuesday, August 08, 2017 3:53 AM
    Tuesday, August 08, 2017 3:53 AM