locked
Timeout error RRS feed

  • Question

  • User-1117295191 posted

    Hi

    I am confused......

    When I wanted to increase the timeout on my site I added the following to the web.config file

        <sessionState       mode="InProc"       cookieless="true"       timeout="90" />

    It worked a treat on my development computer - but then when I uploaded the web.config file and ran online I got the following:

    Server Error in '/' Application. --------------------------------------------------------------------------------

    The resource cannot be found.   Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

     Requested URL: /default.aspx

    I tried uploading the enitire site and still got the same error message.

    I removed the offending code snippet and all worked again (except, of course that the session timeout reverted back to 20 minutes which is most definately not what I want)

    Can anybody help - what am I missing?

    Many thanks

    Saturday, May 3, 2014 3:48 AM

Answers

  • User1546878023 posted

    try setting cookieless to false. when set to true it use query string to pass session information, which can cause many problems

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, May 4, 2014 6:30 PM
  • User-1454326058 posted

    Hi PatrickSlade,

    Based on my test, I can’t reproduce that scene.

    If you want to change the timeout value in the web.config file, you could modify the original web.config file directly. Please try modify it directly and check the result.

    On the other hand, please try to create a new website in the IIS and configure it with the new files.

    Thanks

    Best Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 5, 2014 5:25 AM

All replies

  • User1546878023 posted

    try setting cookieless to false. when set to true it use query string to pass session information, which can cause many problems

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, May 4, 2014 6:30 PM
  • User-1454326058 posted

    Hi PatrickSlade,

    Based on my test, I can’t reproduce that scene.

    If you want to change the timeout value in the web.config file, you could modify the original web.config file directly. Please try modify it directly and check the result.

    On the other hand, please try to create a new website in the IIS and configure it with the new files.

    Thanks

    Best Regards

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, May 5, 2014 5:25 AM