locked
T4 ADO.NET POCO Entity Generator with EF4 and VS2010 SP1 Error RRS feed

  • Question

  • Whenever I attempt to use any generator I only get the "There was a problem getting an AppDomain to run the transformation from the host.  The process cannot continue."  I've searched and have not seen any relevant way to fix this issue.

    Using VS2010 SP1 Premium

    It doesn't seem to matter which Code Generation T4 template I get the same error on all of them.

    I'm trying to attach this to my EDM to generate POCO classes.


    Friday, May 13, 2011 12:17 PM

All replies

  • Hi Steven,

     

    I am writing to check the status of the issue on your side.  Would you mind letting us know the result of the suggestions? 
     
    If you need further assistance, please feel free to let me know.   I will be more than happy to be of assistance.

     

    Have a nice day.


    Alan Chen[MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Thursday, May 26, 2011 9:21 AM
  • I don't know if VS2010 worked okay or not.  I installed VS2010 SP1 and I was unable to generate based on the T4.  I've looked at the solutions provided by the link, but it they did not solve the situation.  I do not have codesmith installed or have the xml tag present.
    Tuesday, May 31, 2011 7:50 PM
  • They suggestions did not help me resolve the situation.
    Tuesday, May 31, 2011 7:51 PM
  • Can you run any T4 template besides the ones that ship with EF? Did you try reinstalling VS?
    Friday, June 3, 2011 7:40 PM