locked
Disable elastic scroll behaviour but keep the scrollbar RRS feed

  • Question

  • When i set a div with 

    overflow:hidden

    The scrollbar appears on it which is very nice. But I want to disable the elastic scrolling behaviour on surface. I tried 

    -ms-touch-action:none

    It works but aslo the scrollbar disappeared. I want to keep the scrollbar but no bounce effect at the edge on a touch screen device.

    Thanks in advance.

    Thursday, November 21, 2013 1:46 PM

Answers

All replies

  • Hi yf liu,

    I'm not quite understand your question, if you set overflow as hidden, your overflow is clipped, and the rest of the content will be invisible, and scrollbar disappear, but not "scrollbar appears on it which is very nice".

    If you want to keep the scrollbar appear, try use overflow:scroll;

    Or I miss something? Please update with me. Thanks.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, November 25, 2013 10:58 AM
    Moderator
  • Take a ponder here: http://msdn.microsoft.com/en-us/library/ie/hh771902(v=vs.85).aspx

    But i don't think you can disable the elastic part of it, maybe in JS you can do it by listening to "touchmove" and preventdefault, thou havent tested if that would work.


    Monday, November 25, 2013 11:43 AM