none
VS 2017 update erro every time

    Question

  • Hello,

    This has been one nagging problem since last 5/6 updates to VS 2017 enterprise edition. Every time I try to upgrade this is where it halts. If I continue/cancel then it gets corrupted, if I retry, I land here every time. I have to completely un-install & install again. Even then it takes a couple of times. This time it absolutely does not work even with a fresh install. It's a showstopper. Please help ASAP.

    I'm using Windows 7 Professional in a corporate environment.


    Thanks & Regards, Sitesh

    Friday, March 09, 2018 3:27 AM

All replies

  • Hi Sitesh,

    Thank you for inserting a picture.
    According to it, something wrong must have happened while downloading files.
    If you are using Wi-Fi, please change it to wired connection (Ethernet), if possible.

    # I recommend to choose [Retry], if the same dialog appears.

    Regards,

    Ashidacchi >> http://hokusosha.com/

    Friday, March 09, 2018 10:45 AM
  • I did it both way, several time. Even retried at least 10-15 times. Every time I land at the exact same spot.

    Thanks & Regards, Sitesh

    Friday, March 09, 2018 3:46 PM
  • Hi Sitesh,

    Welcome to the MSDN forum.

    Refer to the error message, it failed to download the Team Explorer installation file. Please try to open the default browser and access this download link: https://download.visualstudio.microsoft.com/download/pr/11696135/4ba5f4b8bc1d5c694dd9270fc5d26b5a/microsoft.visualstudio.teamexplorer.vsix to download it, then run it as administrator to install.

    >> I'm using Windows 7 Professional in a corporate environment.

    Please make sure your OS is Win7 SP1 and windows update is up-to-date, I tried to upgrade the VS enterprise 2017 from 15.5.6 to 15.6.1 on the Windows 7 computer, the installation complete successfully.

    If this issue persists, I need your help to collect the installation logs. Please use http://aka.ms/vscollect to gather the installation logs and find vslogs.zip under the %temp% folder, then upload the file to Onedrive and share the link here.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, March 12, 2018 5:45 AM
    Moderator
  • Hi Sitesh,

    Do you have any updates? If this issue persists in the latest version, please feel free to let us know.

    If it is solved, we are welcome you share the solution or mark it as answer, that will help other community members who have the similar issue, then we can close this thread for you, thank you for your understanding.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, March 20, 2018 5:52 AM
    Moderator
  • My Apologies for delayed reply. I work in a corporate environment & get things installed takes time here. The issue still persists with the latest installer downloaded from MSDN subscriber downloads. I still get the same error.

    Also, I tried to install team explorer vsix first but it would not install unless visual studio shell is already installed. So that was a bust.

    I also tried creating an offline installer out of the bootstrapper but that too exited with the exact same error. See below --


    Thanks & Regards, Sitesh


    • Edited by Sitesh Thursday, March 22, 2018 4:06 PM
    Thursday, March 22, 2018 1:58 PM
  • Hi Sitesh,

    Thank you for your update.

    Have you tried to download the offline installer at home or from another network? It can help us check if this issue is relates to your corporate environment.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, March 23, 2018 7:09 AM
    Moderator
  • Yes I did. I tried it on a VM on azure. It worked perfectly.

    Thanks & Regards, Sitesh

    Monday, March 26, 2018 2:47 AM
  • Hi Sitesh,

    Please a try with this Fix it tool and you can also try to copy the offline installer from the VM to your local computer to install.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, March 26, 2018 8:07 AM
    Moderator