none
Trying to reserve IP but keep on getting errors

    Question

  • Hey,

    I am quite new to azure, i am trying to add a couple of static ips to my VM, however I keep on getting these errors, no matter what formation of code i use, I have tried it with and without quotation marks, and labels etc.

    New-AzureReservedIP –ReservedIPName reserve1 –Label host –Location Central US

    New-AzureReservedIP –ReservedIPName reserve1 –Location "Central US"

    New-AzureReservedIP –ReservedIPName "reserve1" –Location "Central US"

    New-AzureReservedIP : Method not found: 'Void
    Microsoft.WindowsAzure.Management.Network.Models.NetworkReservedIPCreateParameters.set_VirtualIPName(System.String)'.
    At line:1 char:1
    + New-AzureReservedIP -ReservedIPName "MyServer1IP" -Label "Server1IP" -Location " ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [New-AzureReservedIP], MissingMethodException
     + FullyQualifiedErrorId : System.MissingMethodException,Microsoft.WindowsAzure.Commands.ServiceManagement.IaaS.New
       AzureReservedIPCmdlet		

    the other error that comes up is, no deployment found.

    Friday, June 26, 2015 8:27 PM

All replies

  • Hi,

     Can you check the Azure Module version for powershell, the latest one is listed below.
     
     else try updating to latest azure powershell module following this article : https://azure.microsoft.com/en-in/documentation/articles/powershell-install-configure/
     
     Also the default limit for each subscription is 20 reserved IPs, if you have used all of it, then you may have to delete some ReservedIPs or you can contact azure with a free billing ticket to raise the limit.
     
     let us know if this helps.
     
    Regards,
    Nithin Rathnakar

    Saturday, June 27, 2015 4:31 AM
    Moderator
  • Hi

    i am getting the same issue, i think with the latest release of powershell is throwing the above message when trying to reserve an ip.

    Saturday, June 27, 2015 6:01 PM
  • I'm also having the same issue, have been happily assigning IP addresses to services all week on my other laptop with older version of powershell. New installation(installed yesterday) fails with void error!
    Sunday, June 28, 2015 12:14 PM
  • Just to understand better.

    You want to add and reserve multiple VIP's on your cloud service that holds your VM,right?

    If so please use the follow scripts:

    Add-AzureVirtualIP -ServiceName $ServiceName -VirtualIPName"VIP01"

    Get-AzureVM-ServiceName $Servicename -Name $ServiceName |Add-AzureEndpoint-Name"HTTP"-Protocoltcp-PublicPort80-LocalPort80-VirtualIPName"VIP01"|Update-AzureVM


    New-AzureReservedIP-ServiceNameafifi-group-ReservedIPName"ReserveVIP01"-Location"West Europe"-VirtualIPName"VIP1"

    If you just want o set your internal IP to be static you can do it from the new portal GUI or with this script:

    Get-AzureVM-ServiceName$ServiceName-Name$VM|Set-AzureStaticVNetIP-IPAddress$IP|Update-AzureVM


    • Edited by Ido KatzMVP Monday, June 29, 2015 2:53 PM
    • Proposed as answer by Ido KatzMVP Sunday, July 05, 2015 11:27 AM
    Sunday, June 28, 2015 12:16 PM
  • I have the same issue... Does any one knows how to solve this?
    Sunday, June 28, 2015 6:44 PM
  • I can confirm this too. Was using 0.9.4 (-1) on Friday and was getting this issue. I've stumbled across this thread today, downgraded to 0.9.3 (from Github) and the New-AzureReservedIP routine works fine. The issue must have been introduced indirectly with 0.9.4.

    Old releases can be found at: https://github.com/Azure/azure-powershell/releases

    Monday, June 29, 2015 5:02 AM
  • Same issue for us. Updating to 0.9.4 introduced the problem. Downgrade to 0.9.3 solved it.

    Opened an issue ticket here https://github.com/Azure/azure-powershell/issues/558

    • Edited by Thomas Keey Wednesday, July 01, 2015 2:44 PM
    Wednesday, July 01, 2015 2:40 PM
  • Same problem here .. need a quick update on it. Can't create anymore reserved IP since updated to 0.9.4.

    Do not update 0.9.4, still have some bug


    GIRAUD Alexandre - MVP Forefront France http://www.alexgiraud.net/blog Note : Si ma réponse vous a été utile, ou apporté une résolution; merci de voter ou de la marquer comme réponse.

    Thursday, July 09, 2015 10:59 PM
  • Same version. Same problem as documented by the original poster. This needs to be resolved.
    Sunday, July 12, 2015 10:16 PM
  • Can confirm this issue has been fixed in 0.9.5.
    Wednesday, July 22, 2015 4:31 PM
  • I had the same problem on 0.9.4. After upgrade to 0.9.7. all works well.

    Friday, August 28, 2015 7:38 AM
  • Same issue,

    and it is not even upgrading.

    Friday, April 15, 2016 6:32 PM
  • Try to list the subscriptions you have, then select the correct subscription id, that was my problem.

    Get-AzureSubscription

    and then 


    Select-AzureSubscription -SubscriptionId <subid>
    Wednesday, June 15, 2016 12:32 PM