IIS7. Tried for days to get FTP to work on server 2008!!!!! RRS feed

  • Question

  • User-702378621 posted

     Hi, This is my first post.

     I have been setting up a media server, and want to use ftp for family to access. Right now i am totally stuck, and i think where i have come unstuck is on the verification. I have also been playing around for days now, and could do with starting a clean slate, as i really am so lsot now!.

     First thing i did was install ftp from the roles add in server 08. then later opn removed that, and added iis7 instead, and started again.

    I have setup dyndns. the address is  bristolbulldog.blogdns.com

    I have opened port 21 to the server on my router, and confirmed via dyndns's website that port 21 is open and accepting connections.

    I the got totally confused with anonymous login, anonymous login that appears to the use a local network service, with username, pass through authentication, but then needed ssl as it could be seen easily, then i needed to create a certificate, and the got recommended webdav that also didnt work. grrrrrrrrr!!!!

     have tried ftp.exe and generally end up with some kind of authentication issue, brings up iis7, ftp://internal address brings up a blank ftp directory listing (there are files in there). Going to a higher directory shows 550.

    using the external i.p gets me about as far as my dyn address.

     I have looked alot over these forums, and whislt alot of it is helpful, i jsut can't seem to get this authentication malarky sorted.


    anonymous authentication is enabled (i tried webdav, but the option for windows authentication wasnt there, so i got stuck), and basic is disabled.

    Any idea's? surely setting up ftps should be as simple as allowing traffic, setting user accounts, setting folder, and go! jsut this "setting user accounts" bit is kind of complicated!!!

    Thursday, June 5, 2008 8:23 AM

All replies

  • User-702378621 posted

     getting there now with this article, although so far it only takes me to a local ftp site. In a rush to go out, so will update soon.


    here's the thread on using ssl authentication on ftp. Anyone stuck start here!!!!


    Thursday, June 5, 2008 9:05 AM
  • User-702378621 posted

     ok, another update.

     Using the above guide i got to my ftp site from the server itself.

     i then changed the i.p for the site from local 127... to 192... as it should be.


    I then went to another machine, and tried to access using fireftp in firefox2.

    it reads the certificate, gives me a warning etc, and then throws up and error of 501 server cannot accept argument.


    150 Openign ASCIII mode data connection

    and then

    425 cannot open data connection.

    will keep digging.


    hope someone is finding this stuff useful!!!

    Thursday, June 5, 2008 10:40 AM
  • User-702378621 posted

     This article starts to get things moving on the net, but it still didnt work for me. My best guess (and i could still be wrong), is that it wants your wan i.p, and being a home user, i have a dynamic i.p and use dyndns, so don't know it.

     I also had the issue of it was left as 0-0.

    following the article link at the bottom,


    shows 0-0 in vista/ server 2008 means ports 

    49152 through 65535,

    so i opened these ports on the router, and now it works.

     now i have one thing left, which is creating and adding new user accounts. seem to be stuck on this one last hurdle!

    Thursday, June 5, 2008 11:10 AM
  • User-702378621 posted

     That seems to have solved itself now as well.

    Create a new user, ensure they have permissions for that folder, or add a group that has permissions for that folder,

    go into iis7, under the ftp site, under authorisation, add that userts name.

    didnt work straight away for me, but 5 mins later magically started working.

    all done!

    Thursday, June 5, 2008 11:13 AM