none
Creating a Web Service and VS Asks me if I want to trust the SSL Cert from IIS every time I run the service. RRS feed

  • Question

  • I am developing a web service using Visual Studio 2013 using WCF.  When I need to debug something in the service, I set my app and the service as startup projects.  Every time the Service is a startup project, I get the following:

    You would think you could check the "Don't ask me again" box and be done with it.  This doesn't seem to be working.  This message pops up every time I start the service.  Is there a way to disable this?

    Thanks,

    Jim


    Jim Wilcox

    • Moved by Tina-Shi Thursday, November 6, 2014 8:02 AM the issue is related to the IIS setting
    Wednesday, November 5, 2014 4:19 PM

Answers

  • Hello Amy,

    Thank you for your reply to my inquiry.  Your suggestion didn't work for my situation.  Mainly because I am using the IIS express that is integrated into Visual Studio 2013 and the settings you mentioned don't exist that I could find.  What I wound up doing was to remove the "localhost" certificate from Trusted Root Authorities in IE then I ran VS as administrator.  When I ran the Web Service project, it asked the question I posted in my original post, but this time it took me through the steps to install the certificate.  Since doing that, it has quit showing that dialog every time I start the project.

    Cheers,

    Jim


    Jim Wilcox

    Tuesday, November 25, 2014 2:59 PM

All replies

  • As your issue relates to web app security, I suggest you ask in the ASP.NET forum dedicated to that topic, here:

    http://forums.asp.net/25.aspx/1?Security

    Wednesday, November 5, 2014 4:46 PM
  • I think it has more to do with VS configuration.  There has to be a setting somewhere that is supposed to get set when you check that box.


    Jim Wilcox

    Wednesday, November 5, 2014 5:08 PM
  • Hi Jim Wilcox AIM,

    Please try to click "Yes" to trust the IIS Express SSL certificate. Then it will bring up a security warning stating that you are about to install a certificate from a certificate authority claiming to represent: localhost. Then please click Yes. After that the dialogue box will be away.


    Best Regards,
    Amy Peng

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, November 12, 2014 8:10 AM
    Moderator
  • Hello Amy,

    I always check the "don't show this again" and click yes.  It never tells me it is installing a certificate.  I went so far as to install the certificate manually directly from IE.  No matter what I do, I get the warning.

    Jim


    Jim Wilcox

    Wednesday, November 12, 2014 2:24 PM
  • Hi Jim Wilcox AIM,

    Please try to open your IIS, then right-click your website-->SSL Settings, after that please make sure that you have clicked the Ignore the client certificates box as following:

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Mankdng Nef Tuesday, November 25, 2014 4:56 AM
    • Unproposed as answer by Jim Wilcox AIM Tuesday, November 25, 2014 2:42 PM
    Wednesday, November 19, 2014 7:01 AM
    Moderator
  • Hello Amy,

    Thank you for your reply to my inquiry.  Your suggestion didn't work for my situation.  Mainly because I am using the IIS express that is integrated into Visual Studio 2013 and the settings you mentioned don't exist that I could find.  What I wound up doing was to remove the "localhost" certificate from Trusted Root Authorities in IE then I ran VS as administrator.  When I ran the Web Service project, it asked the question I posted in my original post, but this time it took me through the steps to install the certificate.  Since doing that, it has quit showing that dialog every time I start the project.

    Cheers,

    Jim


    Jim Wilcox

    Tuesday, November 25, 2014 2:59 PM